summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-25 16:26:32 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-27 15:07:29 -0700
commite5a2438e3e94410130a820cad3de65bc53bd0d56 (patch)
treed6d9e9dfeced24dfe9aa875920087756d6ef0d85 /meta-python/recipes-devtools
parent11633d7425e21eaac7e3b1830e2a6cbc89bc4ff7 (diff)
downloadmeta-openembedded-e5a2438e3e94410130a820cad3de65bc53bd0d56.tar.gz
python3-flask: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-flask.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_1.1.1.bb18
2 files changed, 17 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask.inc b/meta-python/recipes-devtools/python/python-flask.inc
deleted file mode 100644
index 1263383da..000000000
--- a/meta-python/recipes-devtools/python/python-flask.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
2DESCRIPTION = "\
3Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
4intentions. And before you ask: It’s BSD licensed!"
5HOMEPAGE = "https://github.com/mitsuhiko/flask/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8
9SRC_URI[md5sum] = "0e3ed44ece1c489ed835d1b7047e349c"
10SRC_URI[sha256sum] = "13f9f196f330c7c2c5d7a5cf91af894110ca0215ac051b5844701f2bfd934d52"
11
12CLEANBROKEN = "1"
13
14PYPI_PACKAGE = "Flask"
15
16RDEPENDS_${PN} = "${PYTHON_PN}-werkzeug ${PYTHON_PN}-jinja2 ${PYTHON_PN}-itsdangerous ${PYTHON_PN}-click"
diff --git a/meta-python/recipes-devtools/python/python3-flask_1.1.1.bb b/meta-python/recipes-devtools/python/python3-flask_1.1.1.bb
index cd439900c..fbe1ca00e 100644
--- a/meta-python/recipes-devtools/python/python3-flask_1.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-flask_1.1.1.bb
@@ -1,2 +1,18 @@
1SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
2DESCRIPTION = "\
3Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
4intentions. And before you ask: It’s BSD licensed!"
5HOMEPAGE = "https://github.com/mitsuhiko/flask/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8
9SRC_URI[md5sum] = "0e3ed44ece1c489ed835d1b7047e349c"
10SRC_URI[sha256sum] = "13f9f196f330c7c2c5d7a5cf91af894110ca0215ac051b5844701f2bfd934d52"
11
12PYPI_PACKAGE = "Flask"
13
1inherit pypi setuptools3 14inherit pypi setuptools3
2require python-flask.inc 15
16CLEANBROKEN = "1"
17
18RDEPENDS_${PN} = "${PYTHON_PN}-werkzeug ${PYTHON_PN}-jinja2 ${PYTHON_PN}-itsdangerous ${PYTHON_PN}-click"