summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2022-08-31 17:45:17 +0800
committerKhem Raj <raj.khem@gmail.com>2022-09-01 00:36:44 -0700
commite253aa31eaccc8dcce224d1b3830b26b2490cfb2 (patch)
tree46a911bf5cbade7e5ac309cf22e7e5856fe29c4a /meta-python/recipes-devtools
parent84ad0699f1c5070e8e57fc07627c6b12412e72bb (diff)
downloadmeta-openembedded-e253aa31eaccc8dcce224d1b3830b26b2490cfb2.tar.gz
python3-pyzmq: Fix buildpaths issue
Fixes: WARNING: python3-pyzmq-23.2.0-r0 do_package_qa: QA Issue: File /usr/lib64/python3.10/site-packages/zmq/utils/config.json in package python3-pyzmq contains reference to TMPDIR File /usr/lib64/python3.10/site-packages/zmq/utils/compiler.json in package python3-pyzmq contains reference to TMPDIR [buildpaths] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq_23.2.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_23.2.1.bb b/meta-python/recipes-devtools/python/python3-pyzmq_23.2.1.bb
index 40cb22b5e..d91d71b27 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_23.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_23.2.1.bb
@@ -43,6 +43,11 @@ do_compile:prepend() {
43 echo no_libzmq_extension = True >> ${S}/setup.cfg 43 echo no_libzmq_extension = True >> ${S}/setup.cfg
44} 44}
45 45
46do_install:append() {
47 sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/config.json
48 sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/compiler.json
49}
50
46do_install_ptest() { 51do_install_ptest() {
47 install -d ${D}${PTEST_PATH}/tests 52 install -d ${D}${PTEST_PATH}/tests
48 cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/ 53 cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/