summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-11-02 16:05:22 +0200
committerKhem Raj <raj.khem@gmail.com>2023-11-02 10:39:36 -0700
commite11e1b763b314e9bd4a0935c2c9c4124a311d6f2 (patch)
treebe5a2d924a2da768860fd8eba45e6bdcdcef13e2 /meta-python/recipes-devtools
parent6fdacd0f2bf8ee302e1a18278fc344d813105f99 (diff)
downloadmeta-openembedded-e11e1b763b314e9bd4a0935c2c9c4124a311d6f2.tar.gz
python3-olefile: add recipe
Add olefile, a package to parse, read and write Microsoft OLE2 files. Version 0.46 changelog: - OleFileIO can now be used as a context manager (with...as), to close the file automatically (see doc). - Improved handling of malformed files. - Fixed several bugs. This work was sponsored by GOVCERT.LU. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-olefile_0.46.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-olefile_0.46.bb b/meta-python/recipes-devtools/python/python3-olefile_0.46.bb
new file mode 100644
index 000000000..e29f30f6f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-olefile_0.46.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Python package to parse, read and write Microsoft OLE2 files"
2HOMEPAGE = "https://github.com/decalage2/olefile"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e21a06208415d5eb2001555d37851362"
5
6SRC_URI[sha256sum] = "133b031eaf8fd2c9399b78b8bc5b8fcbe4c31e85295749bb17a87cba8f3c3964"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "olefile"
11PYPI_PACKAGE_EXT = "zip"
12
13RDEPENDS:${PN} += "\
14 ${PYTHON_PN}-core \
15 ${PYTHON_PN}-datetime \
16 ${PYTHON_PN}-logging \
17"