summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorBen Shelton <ben.shelton@ni.com>2015-02-18 17:03:42 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-27 09:35:51 +0100
commitda6ca531874356077977e9bfed661629a95eb16d (patch)
tree4baac60faaf7bded35bba22dbd5ec82bc86392e3 /meta-python/recipes-devtools
parent8b0a43983c65a2f453d82f909a1860f5770e5041 (diff)
downloadmeta-openembedded-da6ca531874356077977e9bfed661629a95eb16d.tar.gz
python-requests: add recipe
Requests is an HTTP library for Python with a clean and succinct API. Copied from commit bc572006bfcec10523658b8675f30bf45b43a998 in meta-cloud-services/meta-openstack and updated to version 2.5.1. Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.5.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-requests_2.5.1.bb b/meta-python/recipes-devtools/python/python-requests_2.5.1.bb
new file mode 100644
index 000000000..b719dca8d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-requests_2.5.1.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Python HTTP for Humans."
2HOMEPAGE = "http://python-requests.org"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c7869e52c8275537186de35e3cd5f9ec"
6
7PR = "r0"
8SRCNAME = "requests"
9
10SRC_URI = "http://pypi.python.org/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "c270eb5551a02e8ab7a4cbb83e22af2e"
13SRC_URI[sha256sum] = "7b7735efd3b1e2323dc9fcef060b380d05f5f18bd0f247f5e9e74a628279de66"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools