summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-22 02:44:59 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:33:17 -0700
commitd6ccdcb87d4352981bb467bcaf04f7082f279130 (patch)
tree773b873e0e48cc33adc7916e0cf22c36a175718d /meta-python/recipes-devtools
parent9e939d5d908be78640f297e25c2767d7f14c9a6c (diff)
downloadmeta-openembedded-d6ccdcb87d4352981bb467bcaf04f7082f279130.tar.gz
python3-custom-inherit: Add recipe
Add recipe for custom-inherit, a Python package that provides customized docstring inheritance schemes between derived classes and their parents. Changelog for release 2.3.0: - Add three new built-in styles, numpy_with_merge, google_with_merge, and numpy_napoleon_with_merge, which permit users to concatenate the respective sections of a parent's and child's docstrings. - Also add is the ability to configure DocInheritMeta so that special methods will have their docstrings inherited as well. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-custom-inherit_2.3.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-custom-inherit_2.3.0.bb b/meta-python/recipes-devtools/python/python3-custom-inherit_2.3.0.bb
new file mode 100644
index 000000000..489e71984
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-custom-inherit_2.3.0.bb
@@ -0,0 +1,12 @@
1SUMMARY = "A Python package that provides customized docstring inheritance schemes between derived classes and their parents."
2HOMEPAGE = "https://github.com/rsokl/custom_inherit"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=adc1f231c76ee2f1f36025d56926ba2c"
5
6PYPI_PACKAGE = "custom_inherit"
7PYPI_SRC_URI = "https://files.pythonhosted.org/packages/0e/82/c5bb7ec49a7892a2c583e1017597e3921c59171f10602086ca93c8a83baa/custom_inherit-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "adf2850dc0e488df959821a5d4c16cbd"
10SRC_URI[sha256sum] = "1609d283c2cffce3a58baf7c0c22b655c55f85e1ec39c4717a4423d34610723a"
11
12inherit pypi setuptools3