diff options
author | Jan Vermaete <jan.vermaete@gmail.com> | 2024-05-30 21:37:39 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-05-30 14:47:41 -0700 |
commit | c67c3f4232b28ef07e10e30a774ca48a839ffb9c (patch) | |
tree | 4d8165592b7918ec7a49576bb534a023423426b1 /meta-python/recipes-devtools | |
parent | 1d5c3e17f536c600422c61395e58049ee4e1fcfe (diff) | |
download | meta-openembedded-c67c3f4232b28ef07e10e30a774ca48a839ffb9c.tar.gz |
python3-flask: add ptest
* test added to the fast list
Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flask/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flask_3.0.2.bb | 11 |
2 files changed, 13 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask/run-ptest b/meta-python/recipes-devtools/python/python3-flask/run-ptest new file mode 100644 index 0000000000..8d2017d39c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-flask/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-flask_3.0.2.bb b/meta-python/recipes-devtools/python/python3-flask_3.0.2.bb index 300ca99ddc..99524b437b 100644 --- a/meta-python/recipes-devtools/python/python3-flask_3.0.2.bb +++ b/meta-python/recipes-devtools/python/python3-flask_3.0.2.bb | |||
@@ -8,10 +8,14 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" | |||
8 | 8 | ||
9 | SRC_URI[sha256sum] = "822c03f4b799204250a7ee84b1eddc40665395333973dfb9deebfe425fefcb7d" | 9 | SRC_URI[sha256sum] = "822c03f4b799204250a7ee84b1eddc40665395333973dfb9deebfe425fefcb7d" |
10 | 10 | ||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
11 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Flask" | 15 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Flask" |
12 | UPSTREAM_CHECK_REGEX = "/Flask/(?P<pver>(\d+[\.\-_]*)+)" | 16 | UPSTREAM_CHECK_REGEX = "/Flask/(?P<pver>(\d+[\.\-_]*)+)" |
13 | 17 | ||
14 | inherit pypi python_setuptools_build_meta | 18 | inherit pypi python_setuptools_build_meta ptest |
15 | 19 | ||
16 | CLEANBROKEN = "1" | 20 | CLEANBROKEN = "1" |
17 | 21 | ||
@@ -23,3 +27,8 @@ RDEPENDS:${PN} = " \ | |||
23 | python3-profile \ | 27 | python3-profile \ |
24 | python3-werkzeug \ | 28 | python3-werkzeug \ |
25 | " | 29 | " |
30 | |||
31 | do_install_ptest() { | ||
32 | install -d ${D}${PTEST_PATH}/tests | ||
33 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
34 | } | ||