summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorJan Vermaete <jan.vermaete@gmail.com>2024-05-30 21:37:39 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-30 14:47:41 -0700
commitc67c3f4232b28ef07e10e30a774ca48a839ffb9c (patch)
tree4d8165592b7918ec7a49576bb534a023423426b1 /meta-python/recipes-devtools
parent1d5c3e17f536c600422c61395e58049ee4e1fcfe (diff)
downloadmeta-openembedded-c67c3f4232b28ef07e10e30a774ca48a839ffb9c.tar.gz
python3-flask: add ptest
* test added to the fast list Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_3.0.2.bb11
2 files changed, 13 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask/run-ptest b/meta-python/recipes-devtools/python/python3-flask/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-flask_3.0.2.bb b/meta-python/recipes-devtools/python/python3-flask_3.0.2.bb
index 300ca99dd..99524b437 100644
--- a/meta-python/recipes-devtools/python/python3-flask_3.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-flask_3.0.2.bb
@@ -8,10 +8,14 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8 8
9SRC_URI[sha256sum] = "822c03f4b799204250a7ee84b1eddc40665395333973dfb9deebfe425fefcb7d" 9SRC_URI[sha256sum] = "822c03f4b799204250a7ee84b1eddc40665395333973dfb9deebfe425fefcb7d"
10 10
11SRC_URI += " \
12 file://run-ptest \
13"
14
11UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Flask" 15UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Flask"
12UPSTREAM_CHECK_REGEX = "/Flask/(?P<pver>(\d+[\.\-_]*)+)" 16UPSTREAM_CHECK_REGEX = "/Flask/(?P<pver>(\d+[\.\-_]*)+)"
13 17
14inherit pypi python_setuptools_build_meta 18inherit pypi python_setuptools_build_meta ptest
15 19
16CLEANBROKEN = "1" 20CLEANBROKEN = "1"
17 21
@@ -23,3 +27,8 @@ RDEPENDS:${PN} = " \
23 python3-profile \ 27 python3-profile \
24 python3-werkzeug \ 28 python3-werkzeug \
25" 29"
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
34}