summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-12-15 08:52:24 +0100
committerKhem Raj <raj.khem@gmail.com>2023-12-18 22:17:20 -0800
commitb4efcecc63c86f3e7fa9d5c6205f1bd07d951fed (patch)
tree1462ae6308a3a84bdac19c6c17b5c352604b2c97 /meta-python/recipes-devtools
parent6de5e84625c9c46436ba8b9b44842e7b172969eb (diff)
downloadmeta-openembedded-b4efcecc63c86f3e7fa9d5c6205f1bd07d951fed.tar.gz
python3-uinput: remove as unmaintained
Both homepage and downloads are gone, last release in 2016, still relies on distutils which is no longer available in python core as of 3.12. https://pypi.org/project/python-uinput/ Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-uinput/0001-Deal-with-64bit-time_t-default-on-32bit-architecture.patch43
-rw-r--r--meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch30
-rw-r--r--meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb20
3 files changed, 0 insertions, 93 deletions
diff --git a/meta-python/recipes-devtools/python/python3-uinput/0001-Deal-with-64bit-time_t-default-on-32bit-architecture.patch b/meta-python/recipes-devtools/python/python3-uinput/0001-Deal-with-64bit-time_t-default-on-32bit-architecture.patch
deleted file mode 100644
index 4095fc909..000000000
--- a/meta-python/recipes-devtools/python/python3-uinput/0001-Deal-with-64bit-time_t-default-on-32bit-architecture.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 69adf9e32f5b11e15c0cbe17f9331c77fed65bf8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 28 May 2022 15:50:50 -0700
4Subject: [PATCH] Deal with 64bit time_t default on 32bit architectures
5
6Deal with Y2K38 concerns related to Linux input events on more recent
7kernels and libcs on 32-bit systems
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 libsuinput/src/suinput.c | 11 ++++++++++-
13 1 file changed, 10 insertions(+), 1 deletion(-)
14
15diff --git a/libsuinput/src/suinput.c b/libsuinput/src/suinput.c
16index 8d5fb71..13ff16a 100644
17--- a/libsuinput/src/suinput.c
18+++ b/libsuinput/src/suinput.c
19@@ -45,11 +45,20 @@ int suinput_emit(int uinput_fd, uint16_t ev_type, uint16_t ev_code,
20 struct input_event event;
21
22 memset(&event, 0, sizeof(event));
23- gettimeofday(&event.time, 0);
24 event.type = ev_type;
25 event.code = ev_code;
26 event.value = ev_value;
27
28+/* attempt to deal with 64-bit time keeping on recent 32-bit systems */
29+#if (__BITS_PER_LONG != 32 || !defined(__USE_TIME_BITS64))
30+ gettimeofday(&event.time, 0);
31+#else
32+ struct timeval now;
33+ memset(&now, 0, sizeof(now));
34+ gettimeofday(&now, 0);
35+ event.input_event_sec = now.tv_sec;
36+ event.input_event_usec = now.tv_usec;
37+#endif
38 return suinput_write_event(uinput_fd, &event);
39 }
40
41--
422.36.1
43
diff --git a/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch
deleted file mode 100644
index b2e1b9cd8..000000000
--- a/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 7a4dde83a9584adb42c7f810d882b1fbf5767e2c Mon Sep 17 00:00:00 2001
2From: Bartosz Golaszewski <brgl@bgdev.pl>
3Date: Tue, 24 May 2022 21:43:35 +0200
4Subject: [PATCH] setup: use setuptools instead of distutils
5
6The latter is deprecated, use setuptools instead.
7
8Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
9---
10Upstream-Status: Pending
11
12 setup.py | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/setup.py b/setup.py
16index 3fa3343..4900b8b 100644
17--- a/setup.py
18+++ b/setup.py
19@@ -3,7 +3,7 @@
20 import errno
21 import subprocess
22
23-from distutils.core import setup, Extension
24+from setuptools import setup, Extension
25
26 libudev_so = "libudev.so.1"
27
28--
292.34.1
30
diff --git a/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb b/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb
deleted file mode 100644
index ef466539b..000000000
--- a/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "Python interface to Linux uinput kernel module."
2HOMEPAGE = "https://pypi.org/project/python-uinput/"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
5
6SRC_URI += "file://0001-setup-use-setuptools-instead-of-distutils.patch \
7 file://0001-Deal-with-64bit-time_t-default-on-32bit-architecture.patch \
8"
9SRC_URI[sha256sum] = "99392b676c77b5795b86b7d75274db33fe754fd1e06fb3d58b167c797dc47f0c"
10
11PYPI_PACKAGE = "python-uinput"
12
13inherit pypi setuptools3
14
15DEPENDS += "udev"
16RDEPENDS:${PN} += " \
17 python3-ctypes \
18 python3-distutils \
19"
20RRECOMMENDS:${PN} += "kernel-module-uinput"