summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-29 00:34:56 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-31 07:38:06 -0700
commitb3375a4adc915ba19afd51471613edaa221658c8 (patch)
treefa3dbc8773388014f10bd8029f1d05c30956c368 /meta-python/recipes-devtools
parenta603cfc4ddf938841f212782b8dc0cab02139eb7 (diff)
downloadmeta-openembedded-b3375a4adc915ba19afd51471613edaa221658c8.tar.gz
python3-grpcio: Update to 1.38.0
Drop riscv patch as its applied upstream Refresh patches Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/mips_bigendian.patch2
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch21
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.38.0.bb (renamed from meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb)4
3 files changed, 2 insertions, 25 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/mips_bigendian.patch b/meta-python/recipes-devtools/python/python3-grpcio/mips_bigendian.patch
index 343f25a46..775afa415 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio/mips_bigendian.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio/mips_bigendian.patch
@@ -12,4 +12,4 @@
12+#elif defined(__mips__) && defined(__LP64__) 12+#elif defined(__mips__) && defined(__LP64__)
13 #define OPENSSL_64_BIT 13 #define OPENSSL_64_BIT
14 #define OPENSSL_MIPS64 14 #define OPENSSL_MIPS64
15 #elif defined(__riscv) 15 #elif defined(__riscv) && __SIZEOF_POINTER__ == 8
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch b/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch
deleted file mode 100644
index 350c67dea..000000000
--- a/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch
+++ /dev/null
@@ -1,21 +0,0 @@
1Add RISC-V 64bit support
2
3Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5--- a/third_party/boringssl-with-bazel/src/include/openssl/base.h
6+++ b/third_party/boringssl-with-bazel/src/include/openssl/base.h
7@@ -108,6 +108,14 @@ extern "C" {
8 #elif defined(__MIPSEL__) && defined(__LP64__)
9 #define OPENSSL_64_BIT
10 #define OPENSSL_MIPS64
11+#elif defined(__riscv)
12+# if (__riscv_xlen == 64)
13+# define OPENSSL_64_BIT
14+# define OPENSSL_RISCV64
15+# elif(__riscv_xlen == 32)
16+# define OPENSSL_32_BIT
17+# define OPENSSL_RISCV32
18+# endif
19 #elif defined(__pnacl__)
20 #define OPENSSL_32_BIT
21 #define OPENSSL_PNACL
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.38.0.bb
index 47fb71120..d9e00422b 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio_1.37.0.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.38.0.bb
@@ -8,12 +8,11 @@ DEPENDS += "${PYTHON_PN}-protobuf"
8 8
9SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" 9SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
10SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \ 10SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \
11 file://riscv64_support.patch \
12 file://boring_ssl.patch \ 11 file://boring_ssl.patch \
13 file://mips_bigendian.patch \ 12 file://mips_bigendian.patch \
14 file://0001-absl-always-use-asm-sgidefs.h.patch \ 13 file://0001-absl-always-use-asm-sgidefs.h.patch \
15" 14"
16SRC_URI[sha256sum] = "b3ce16aa91569760fdabd77ca901b2288152eb16941d28edd9a3a75a0c4a8a85" 15SRC_URI[sha256sum] = "abbf9c8c3df4d5233d5888c6cfa85c1bb68a6923749bd4dd1abc6e1e93986f17"
17 16
18RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \ 17RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
19 ${PYTHON_PN}-setuptools \ 18 ${PYTHON_PN}-setuptools \
@@ -46,4 +45,3 @@ CCACHE_DISABLE = "1"
46 45
47# needs vdso support 46# needs vdso support
48COMPATIBLE_HOST_libc-musl_powerpc64le = "null" 47COMPATIBLE_HOST_libc-musl_powerpc64le = "null"
49