summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-05 18:52:11 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-05 11:02:05 -0800
commita4ee3123dbf759ed466c6e156f2fb575d0d9c484 (patch)
tree89f4152a10f51d956dab37aece3cec686d4b38d9 /meta-python/recipes-devtools
parentf4eefe2a818c9184b46d450b1d6f474a4bfc18ea (diff)
downloadmeta-openembedded-a4ee3123dbf759ed466c6e156f2fb575d0d9c484.tar.gz
python3-arrow: add ptest, update backend and runtime dependencies
* Upstream provides a pyproject.toml which declares a flit_core.buildapi build backend instead of setuptools. * Updated runtime dependencies. * Ptest and library example tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_SLOW_META_PYTHON Ptest result: ============= qemux86-64: Testsuite summary TOTAL: 1839 PASS: 1836 SKIP: 1 XFAIL: 1 FAIL: 0 XPASS: 1 ERROR: 0 DURATION: 146 END: /usr/lib/python3-arrow/ptest 2024-03-05T12:57 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 1839 PASS: 1836 SKIP: 1 XFAIL: 1 FAIL: 0 XPASS: 1 ERROR: 0 DURATION: 130 END: /usr/lib/python3-arrow/ptest 2024-03-05T12:51 STOP: ptest-runner TOTAL: 1 FAIL: 0 XFAIL AND XPASS known issue with humanize month limits Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-arrow/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb30
2 files changed, 29 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-arrow/run-ptest b/meta-python/recipes-devtools/python/python3-arrow/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-arrow/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb b/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
index 90ba5de96..c1b7c1a43 100644
--- a/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb
@@ -1,13 +1,35 @@
1SUMMARY = "Better dates and times for Python" 1SUMMARY = "Better dates and times for Python"
2HOMEPAGE = "https://github.com/crsmithdev/arrow" 2HOMEPAGE = "https://github.com/arrow-py/arrow"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=14a2e29a9d542fb9052d75344d67619d" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=14a2e29a9d542fb9052d75344d67619d"
6 6
7SRC_URI[sha256sum] = "d4540617648cb5f895730f1ad8c82a65f2dad0166f57b75f3ca54759c4d67a85" 7SRC_URI[sha256sum] = "d4540617648cb5f895730f1ad8c82a65f2dad0166f57b75f3ca54759c4d67a85"
8 8
9inherit setuptools3 pypi 9inherit pypi python_flit_core ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 python3-dateutil-zoneinfo \
17 python3-pytest \
18 python3-pytest-mock \
19 python3-pytz \
20 python3-simplejson \
21 python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
10 28
11RDEPENDS:${PN} += " \ 29RDEPENDS:${PN} += " \
12 python3-dateutil \ 30 python3-compression \
13 " 31 python3-dateutil \
32 python3-dateutil-zoneinfo \
33 python3-json \
34 python3-types-python-dateutil \
35"