diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-11-26 12:54:39 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-11-26 10:07:02 -0800 |
commit | 9b3c3c080382d6b557705978c6719edc5ef4a2db (patch) | |
tree | f36756945aad86d2d392d39a1f0902af574b8c90 /meta-python/recipes-devtools | |
parent | 2fb000b020adf89478aa08e1f5d7f2e9c1813e2a (diff) | |
download | meta-openembedded-9b3c3c080382d6b557705978c6719edc5ef4a2db.tar.gz |
python: remove recipes imported to oe-core
To support device tree schema validation in kernels v5.16+, we've
imported dt-schema + dependencies to core. So we can safely drop
them from meta-python.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
14 files changed, 0 insertions, 270 deletions
diff --git a/meta-python/recipes-devtools/python/python-rfc3986-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch b/meta-python/recipes-devtools/python/python-rfc3986-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch deleted file mode 100644 index 8a646874e..000000000 --- a/meta-python/recipes-devtools/python/python-rfc3986-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 3531ff73631a0d59234eb4713e7b3a7f5ea57bbb Mon Sep 17 00:00:00 2001 | ||
2 | From: Nicola Lunghi <nicola.lunghi@jci.com> | ||
3 | Date: Thu, 14 Nov 2019 12:17:51 +0000 | ||
4 | Subject: [PATCH] setup.py: move pytest-runner to test_requirements | ||
5 | |||
6 | This fixes an issue with yocto build. | ||
7 | pytest-runner is only needed when running tests. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | --- | ||
11 | setup.py | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 53ebea7..ebb0de2 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -10,9 +10,9 @@ with open('README.md') as readme_file: | ||
19 | |||
20 | requirements = [] | ||
21 | |||
22 | -setup_requirements = ['pytest-runner', ] | ||
23 | +setup_requirements = [] | ||
24 | |||
25 | -test_requirements = ['pytest>=3', ] | ||
26 | +test_requirements = ['pytest>=3', 'pytest-runner'] | ||
27 | |||
28 | setup( | ||
29 | author="Nicolas Aimetti", | ||
30 | -- | ||
31 | 2.20.1 | ||
32 | |||
diff --git a/meta-python/recipes-devtools/python/python3-idna_3.3.bb b/meta-python/recipes-devtools/python/python3-idna_3.3.bb deleted file mode 100644 index a0e6b79a5..000000000 --- a/meta-python/recipes-devtools/python/python3-idna_3.3.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | SUMMARY = "Internationalised Domain Names in Applications" | ||
2 | HOMEPAGE = "https://github.com/kjd/idna" | ||
3 | LICENSE = "BSD-3-Clause & Python-2.0 & Unicode" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=239668a7c6066d9e0c5382e9c8c6c0e1" | ||
5 | |||
6 | SRC_URI[sha256sum] = "9d643ff0a55b762d5cdb124b8eaa99c66322e2157b69160bc32796e824360e6d" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | # Remove bundled egg-info | ||
11 | do_compile:prepend() { | ||
12 | rm -rf ${S}/idna.egg-info | ||
13 | } | ||
14 | |||
15 | RDEPENDS:${PN}:class-target = "\ | ||
16 | ${PYTHON_PN}-codecs \ | ||
17 | " | ||
18 | |||
19 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-jsonpointer/run-ptest b/meta-python/recipes-devtools/python/python3-jsonpointer/run-ptest deleted file mode 100644 index 51e609f4b..000000000 --- a/meta-python/recipes-devtools/python/python3-jsonpointer/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | python3 tests.py | ||
diff --git a/meta-python/recipes-devtools/python/python3-jsonpointer_2.2.bb b/meta-python/recipes-devtools/python/python3-jsonpointer_2.2.bb deleted file mode 100644 index 225fde755..000000000 --- a/meta-python/recipes-devtools/python/python3-jsonpointer_2.2.bb +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | SUMMARY = "Resolve JSON Pointers in Python" | ||
2 | HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3" | ||
5 | |||
6 | inherit pypi ptest setuptools3 | ||
7 | |||
8 | SRC_URI[sha256sum] = "f09f8deecaaa5aea65b5eb4f67ca4e54e1a61f7a11c75085e360fe6feb6a48bf" | ||
9 | |||
10 | RDEPENDS:${PN} += " \ | ||
11 | ${PYTHON_PN}-json \ | ||
12 | " | ||
13 | |||
14 | BBCLASSEXTEND = "native nativesdk" | ||
15 | |||
16 | SRC_URI += " \ | ||
17 | file://run-ptest \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS:${PN}-ptest += " \ | ||
21 | ${PYTHON_PN}-pytest \ | ||
22 | " | ||
23 | |||
24 | do_install_ptest() { | ||
25 | cp -f ${S}/tests.py ${D}${PTEST_PATH}/ | ||
26 | } | ||
diff --git a/meta-python/recipes-devtools/python/python3-jsonschema_3.2.0.bb b/meta-python/recipes-devtools/python/python3-jsonschema_3.2.0.bb deleted file mode 100644 index c7efe33a8..000000000 --- a/meta-python/recipes-devtools/python/python3-jsonschema_3.2.0.bb +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | SUMMARY = "An implementation of JSON Schema validation for Python" | ||
2 | HOMEPAGE = "https://github.com/Julian/jsonschema" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \ | ||
5 | file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af" | ||
6 | DEPENDS += "${PYTHON_PN}-vcversioner-native ${PYTHON_PN}-setuptools-scm-native" | ||
7 | |||
8 | SRC_URI[md5sum] = "f1a0b5011f05a02a8dee1070cd10a26d" | ||
9 | SRC_URI[sha256sum] = "c8a85b28d377cc7737e46e2d9f2b4f44ee3c0e1deac6bf46ddefc7187d30797a" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | PACKAGECONFIG ??= "format" | ||
14 | PACKAGECONFIG[format] = ",,,\ | ||
15 | ${PYTHON_PN}-idna \ | ||
16 | ${PYTHON_PN}-jsonpointer \ | ||
17 | ${PYTHON_PN}-webcolors \ | ||
18 | ${PYTHON_PN}-rfc3987 \ | ||
19 | ${PYTHON_PN}-strict-rfc3339 \ | ||
20 | " | ||
21 | PACKAGECONFIG[nongpl] = ",,,\ | ||
22 | ${PYTHON_PN}-idna \ | ||
23 | ${PYTHON_PN}-jsonpointer \ | ||
24 | ${PYTHON_PN}-webcolors \ | ||
25 | ${PYTHON_PN}-rfc3986-validator \ | ||
26 | ${PYTHON_PN}-rfc3339-validator \ | ||
27 | " | ||
28 | |||
29 | RDEPENDS:${PN} += " \ | ||
30 | ${PYTHON_PN}-attrs \ | ||
31 | ${PYTHON_PN}-core \ | ||
32 | ${PYTHON_PN}-datetime \ | ||
33 | ${PYTHON_PN}-importlib-metadata \ | ||
34 | ${PYTHON_PN}-io \ | ||
35 | ${PYTHON_PN}-json \ | ||
36 | ${PYTHON_PN}-netclient \ | ||
37 | ${PYTHON_PN}-numbers \ | ||
38 | ${PYTHON_PN}-pkgutil \ | ||
39 | ${PYTHON_PN}-pprint \ | ||
40 | ${PYTHON_PN}-pyrsistent \ | ||
41 | ${PYTHON_PN}-shell \ | ||
42 | ${PYTHON_PN}-six \ | ||
43 | ${PYTHON_PN}-unittest \ | ||
44 | ${PYTHON_PN}-setuptools-scm \ | ||
45 | ${PYTHON_PN}-zipp \ | ||
46 | " | ||
47 | |||
48 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb b/meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb deleted file mode 100644 index 0b4d2564f..000000000 --- a/meta-python/recipes-devtools/python/python3-pyrsistent_0.18.0.bb +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | SUMMARY = "Persistent/Immutable/Functional data structures for Python" | ||
2 | HOMEPAGE = "https://github.com/tobgu/pyrsistent" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=a4b94c2b800b582a8d3925a9939cbf44" | ||
5 | |||
6 | SRC_URI[sha256sum] = "773c781216f8c2900b42a7b638d5b517bb134ae1acbebe4d1e8f1f41ea60eb4b" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | RDEPENDS:${PN} += " \ | ||
11 | ${PYTHON_PN}-numbers \ | ||
12 | " | ||
13 | |||
14 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb deleted file mode 100644 index 7f1bbaf97..000000000 --- a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.4.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | SUMMARY = "A pure python RFC3339 validator" | ||
2 | HOMEPAGE = "https://github.com/naimetti/rfc3339-validator" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6" | ||
5 | |||
6 | FILESEXTRAPATHS:prepend := "${THISDIR}/python-rfc3339-validator:" | ||
7 | |||
8 | SRC_URI[sha256sum] = "138a2abdf93304ad60530167e51d2dfb9549521a836871b88d7f4695d0022f6b" | ||
9 | |||
10 | PYPI_PACKAGE = "rfc3339_validator" | ||
11 | |||
12 | inherit pypi setuptools3 | ||
13 | |||
14 | RDEPENDS:${PN} += "\ | ||
15 | ${PYTHON_PN}-core \ | ||
16 | ${PYTHON_PN}-datetime \ | ||
17 | ${PYTHON_PN}-six \ | ||
18 | " | ||
19 | |||
20 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb b/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb deleted file mode 100644 index 68b3db1f4..000000000 --- a/meta-python/recipes-devtools/python/python3-rfc3986-validator_0.1.1.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | SUMMARY = "Pure python rfc3986 validator" | ||
2 | HOMEPAGE = "https://github.com/naimetti/rfc3986-validator" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6" | ||
5 | |||
6 | FILESEXTRAPATHS:prepend := "${THISDIR}/python-rfc3986-validator:" | ||
7 | |||
8 | SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95" | ||
9 | SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055" | ||
10 | |||
11 | PYPI_PACKAGE = "rfc3986_validator" | ||
12 | |||
13 | inherit pypi setuptools3 | ||
14 | |||
15 | SRC_URI:append = " \ | ||
16 | file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS:${PN} += "\ | ||
20 | python3-core \ | ||
21 | " | ||
22 | |||
23 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-rfc3987_1.3.8.bb b/meta-python/recipes-devtools/python/python3-rfc3987_1.3.8.bb deleted file mode 100644 index 80e2aa5bc..000000000 --- a/meta-python/recipes-devtools/python/python3-rfc3987_1.3.8.bb +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | SUMMARY = "Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)" | ||
2 | LICENSE = "GPLv3+" | ||
3 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=9;md5=2b723edf67b2f3088bc5e339b1ceda2d" | ||
4 | |||
5 | SRC_URI[md5sum] = "b6c4028acdc788a9ba697e1c1d6b896c" | ||
6 | SRC_URI[sha256sum] = "d3c4d257a560d544e9826b38bc81db676890c79ab9d7ac92b39c7a253d5ca733" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.16.bb b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.16.bb deleted file mode 100644 index e64f19600..000000000 --- a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.16.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order." | ||
2 | AUTHOR = "Anthon van der Neut" | ||
3 | |||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fa0a51dfb461e2f803969e0f3fa71dfe" | ||
6 | |||
7 | PYPI_PACKAGE = "ruamel.yaml" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | SRC_URI[sha256sum] = "1a771fc92d3823682b7f0893ad56cb5a5c87c48e62b5399d6f42c8759a583b33" | ||
12 | |||
13 | RDEPENDS:${PN} += "\ | ||
14 | ${PYTHON_PN}-shell \ | ||
15 | ${PYTHON_PN}-datetime \ | ||
16 | ${PYTHON_PN}-netclient \ | ||
17 | " | ||
18 | |||
19 | do_install:prepend() { | ||
20 | export RUAMEL_NO_PIP_INSTALL_CHECK=1 | ||
21 | } | ||
22 | |||
23 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-strict-rfc3339_0.7.bb b/meta-python/recipes-devtools/python/python3-strict-rfc3339_0.7.bb deleted file mode 100644 index 52ae9ebe9..000000000 --- a/meta-python/recipes-devtools/python/python3-strict-rfc3339_0.7.bb +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | SUMMARY = "Strict, simple, lightweight RFC3339 function.s" | ||
2 | LICENSE = "GPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f0e2cd40e05189ec81232da84bd6e1a" | ||
4 | |||
5 | SRC_URI[md5sum] = "4d9b635b4df885bc37bc1189d66c9abc" | ||
6 | SRC_URI[sha256sum] = "5cad17bedfc3af57b399db0fed32771f18fc54bbd917e85546088607ac5e1277" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb b/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb deleted file mode 100644 index 149078c51..000000000 --- a/meta-python/recipes-devtools/python/python3-vcversioner_2.16.0.0.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | SUMMARY = "Python vcversioner, automagically update the project's version" | ||
2 | HOMEPAGE = "https://github.com/habnabit/vcversioner" | ||
3 | |||
4 | LICENSE = "ISC" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=827a7a91a8d20d3c666b665cd96db8e3" | ||
6 | |||
7 | SRC_URI[md5sum] = "aab6ef5e0cf8614a1b1140ed5b7f107d" | ||
8 | SRC_URI[sha256sum] = "dae60c17a479781f44a4010701833f1829140b1eeccd258762a74974aa06e19b" | ||
9 | |||
10 | inherit pypi setuptools3 | ||
11 | |||
12 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-python/recipes-devtools/python/python3-webcolors/run-ptest b/meta-python/recipes-devtools/python/python3-webcolors/run-ptest deleted file mode 100644 index 3385d6893..000000000 --- a/meta-python/recipes-devtools/python/python3-webcolors/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb b/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb deleted file mode 100644 index 2ec036ef3..000000000 --- a/meta-python/recipes-devtools/python/python3-webcolors_1.11.1.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | SUMMARY = "Simple Python module for working with HTML/CSS color definitions." | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=25b90379a52351261c51272e7923d240" | ||
4 | |||
5 | SRC_URI[md5sum] = "54d28a7c80b3e4d974ec2fee86768be9" | ||
6 | SRC_URI[sha256sum] = "76f360636957d1c976db7466bc71dcb713bb95ac8911944dffc55c01cb516de6" | ||
7 | |||
8 | inherit pypi setuptools3 ptest | ||
9 | |||
10 | RDEPENDS:${PN}:class-target = "\ | ||
11 | ${PYTHON_PN}-stringold \ | ||
12 | " | ||
13 | |||
14 | SRC_URI += " \ | ||
15 | file://run-ptest \ | ||
16 | " | ||
17 | |||
18 | RDEPENDS:${PN}-ptest += " \ | ||
19 | ${PYTHON_PN}-pytest \ | ||
20 | " | ||
21 | |||
22 | do_install_ptest() { | ||
23 | install -d ${D}${PTEST_PATH}/tests | ||
24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
25 | } | ||
26 | |||
27 | BBCLASSEXTEND = "native nativesdk" | ||