diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-10-18 22:38:24 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-10-26 10:28:38 +0200 |
commit | 71670ffaac42443f8de75d09be722adbb4ff3a51 (patch) | |
tree | f7ad559a9427330af5bce80c44a124fbb071f56c /meta-python/recipes-devtools | |
parent | 73c68712737e17d5166189d54a17a8107175c2dc (diff) | |
download | meta-openembedded-71670ffaac42443f8de75d09be722adbb4ff3a51.tar.gz |
python-greenlet: Rename register from rX to xX for aarch64
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python-greenlet/0001-Use-x-instead-of-r-for-aarch64-register-names.patch | 38 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-greenlet_0.4.9.bb | 3 |
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-greenlet/0001-Use-x-instead-of-r-for-aarch64-register-names.patch b/meta-python/recipes-devtools/python/python-greenlet/0001-Use-x-instead-of-r-for-aarch64-register-names.patch new file mode 100644 index 000000000..4868bf3bc --- /dev/null +++ b/meta-python/recipes-devtools/python/python-greenlet/0001-Use-x-instead-of-r-for-aarch64-register-names.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From b53fb3bf861f895034452e984f2accb8bebbd3c9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Fredrik Fornwall <fredrik@fornwall.net> | ||
3 | Date: Wed, 7 Sep 2016 09:25:54 +0200 | ||
4 | Subject: [PATCH] Use x instead of r for aarch64 register names | ||
5 | |||
6 | This fixes clang compatibility. | ||
7 | --- | ||
8 | Upstream-Status: Backport | ||
9 | |||
10 | platform/switch_aarch64_gcc.h | 5 +++-- | ||
11 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/platform/switch_aarch64_gcc.h b/platform/switch_aarch64_gcc.h | ||
14 | index 2fbc569..0b9d556 100644 | ||
15 | --- a/platform/switch_aarch64_gcc.h | ||
16 | +++ b/platform/switch_aarch64_gcc.h | ||
17 | @@ -2,6 +2,7 @@ | ||
18 | * this is the internal transfer function. | ||
19 | * | ||
20 | * HISTORY | ||
21 | + * 07-Sep-16 Add clang support using x register naming. Fredrik Fornwall | ||
22 | * 13-Apr-13 Add support for strange GCC caller-save decisions | ||
23 | * 08-Apr-13 File creation. Michael Matz | ||
24 | * | ||
25 | @@ -15,8 +16,8 @@ | ||
26 | |||
27 | #ifdef SLP_EVAL | ||
28 | #define STACK_MAGIC 0 | ||
29 | -#define REGS_TO_SAVE "r19", "r20", "r21", "r22", "r23", "r24", "r25", "r26", \ | ||
30 | - "r27", "r28", "r30" /* aka lr */, \ | ||
31 | +#define REGS_TO_SAVE "x19", "x20", "x21", "x22", "x23", "x24", "x25", "x26", \ | ||
32 | + "x27", "x28", "x30" /* aka lr */, \ | ||
33 | "v8", "v9", "v10", "v11", \ | ||
34 | "v12", "v13", "v14", "v15" | ||
35 | |||
36 | -- | ||
37 | 1.9.1 | ||
38 | |||
diff --git a/meta-python/recipes-devtools/python/python-greenlet_0.4.9.bb b/meta-python/recipes-devtools/python/python-greenlet_0.4.9.bb index c1bc21465..4c0faf572 100644 --- a/meta-python/recipes-devtools/python/python-greenlet_0.4.9.bb +++ b/meta-python/recipes-devtools/python/python-greenlet_0.4.9.bb | |||
@@ -3,6 +3,9 @@ LICENSE = "MIT & PSF" | |||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \ | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \ |
4 | file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a" | 4 | file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a" |
5 | 5 | ||
6 | SRC_URI += "\ | ||
7 | file://0001-Use-x-instead-of-r-for-aarch64-register-names.patch \ | ||
8 | " | ||
6 | SRC_URI[md5sum] = "c6659cdb2a5e591723e629d2eef22e82" | 9 | SRC_URI[md5sum] = "c6659cdb2a5e591723e629d2eef22e82" |
7 | SRC_URI[sha256sum] = "58b2f3a2e7075c655616bf95e82868db4980f3bb6661db70ad02a51e4ddd2252" | 10 | SRC_URI[sha256sum] = "58b2f3a2e7075c655616bf95e82868db4980f3bb6661db70ad02a51e4ddd2252" |
8 | 11 | ||