summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2020-02-14 15:18:27 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit701290f6e4bbe70471e6f2be0a51540ac69f383b (patch)
tree4f90dd7cf9f8c26e411bd6c1a5e8c866cc6c9158 /meta-python/recipes-devtools
parentd4b54a9c612c20c2583410a22cb5d0d54958c5e8 (diff)
downloadmeta-openembedded-701290f6e4bbe70471e6f2be0a51540ac69f383b.tar.gz
pytest-metadata: Add new package
Adds plugin support for accessing pytest metadata. Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-metadata_1.8.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-metadata_1.8.0.bb b/meta-python/recipes-devtools/python/python3-pytest-metadata_1.8.0.bb
new file mode 100644
index 000000000..807b0cedb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-metadata_1.8.0.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "pytest-metadata is a plugin that allowed for accessing pytest metadata"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-metadata"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
5
6PYPI_PACKAGE = "pytest-metadata"
7
8inherit pypi setuptools3
9
10SRC_URI[md5sum] = "95674c2390b58e0138cabac5101d1908"
11SRC_URI[sha256sum] = "2071a59285de40d7541fde1eb9f1ddea1c9db165882df82781367471238b66ba"
12
13DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
14
15RDEPENDS_${PN} = "${PYTHON_PN}-pytest"