diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-10-21 14:16:09 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-10-22 22:17:30 -0700 |
commit | 1a53121ff54732648a4ee1e96643106d4d36c524 (patch) | |
tree | 588e71bd20b2f8bad10e9fad9c7049d7967ed2ae /meta-python/recipes-devtools | |
parent | aa4f5c9f968cba62ae95132b2000d57e12809bcc (diff) | |
download | meta-openembedded-1a53121ff54732648a4ee1e96643106d4d36c524.tar.gz |
python3-typeguard: Upgrade 2.9.1 -> 2.10.0
Upgrade to release 2.10.0:
- Added support for Python 3.9
- Added support for nested Literal
- Added support for TypedDict inheritance (with some caveats; see
the user guide on that for details)
- An appropriate TypeError is now raised when encountering an
illegal Literal value
- Fixed checking NoReturn on Python < 3.8 when typing_extensions
was not installed
- Fixed import hook matching unwanted modules
- Install the pytest plugin earlier in the test run to support
more use cases
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb (renamed from meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb) | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb b/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb index 3786ccb85..bd9221677 100644 --- a/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb +++ b/meta-python/recipes-devtools/python/python3-typeguard_2.10.0.bb | |||
@@ -3,8 +3,8 @@ HOMEPAGE = "https://pypi.org/project/typeguard/" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53" |
5 | 5 | ||
6 | SRC_URI[md5sum] = "411df8eefd76ffa014328a46342bdf38" | 6 | SRC_URI[md5sum] = "cc43e0eb1dea7e409a74c7f1effc4544" |
7 | SRC_URI[sha256sum] = "529ef3d88189cc457f4340388028412f71be8091c2c943465146d4170fb67288" | 7 | SRC_URI[sha256sum] = "d830132dcd544d3f8a2a842ea739eaa0d7c099fcebb9dcdf3802f4c9929d8191" |
8 | 8 | ||
9 | inherit pypi setuptools3 ptest | 9 | inherit pypi setuptools3 ptest |
10 | 10 | ||