summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-03-22 13:53:53 +0800
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commit0d9ca0ba17242b82861d68e06bde1ba1692fd842 (patch)
tree29a65f8a48c9aba91a880739cd75a36c1d94952d /meta-python/recipes-devtools
parent20af599f61671218a48f8c6f20afe1573dd4be2c (diff)
downloadmeta-openembedded-0d9ca0ba17242b82861d68e06bde1ba1692fd842.tar.gz
python-m2crypto: refresh patch
Fix QA warning: WARNING: python-m2crypto-native-0.26.4-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch 0001-setup.py-link-in-sysroot-not-in-host-directories.patch patching file setup.py Hunk #1 succeeded at 127 with fuzz 1 (offset 65 lines). Hunk #2 succeeded at 143 (offset 68 lines). Now at patch 0001-setup.py-link-in-sysroot-not-in-host-directories.patch Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch19
1 files changed, 11 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index 819c8e569..c71b16fec 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -1,4 +1,4 @@
1From f11b9c71080513f9b867ba8f40613ba2ebc6e960 Mon Sep 17 00:00:00 2001 1From dfb83a41aaeae326e9b6f02b233af375bc7b8815 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 29 Mar 2013 15:17:17 +0100 3Date: Fri, 29 Mar 2013 15:17:17 +0100
4Subject: [PATCH] setup.py: link in sysroot, not in host directories 4Subject: [PATCH] setup.py: link in sysroot, not in host directories
@@ -10,12 +10,12 @@ Upstream-status: Unknown
10 setup.py | 6 +++--- 10 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 3 deletions(-) 11 1 file changed, 3 insertions(+), 3 deletions(-)
12 12
13Index: M2Crypto-0.23.0/setup.py 13diff --git a/setup.py b/setup.py
14=================================================================== 14index 3407c82..15ed7cd 100644
15--- M2Crypto-0.23.0.orig/setup.py 15--- a/setup.py
16+++ M2Crypto-0.23.0/setup.py 16+++ b/setup.py
17@@ -62,7 +62,7 @@ class _M2CryptoBuildExt(build_ext.build_ 17@@ -127,7 +127,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
18 self.openssl = 'c:\\pkg' 18 self.openssl = os.path.join(self.openssl, 'OpenSSL')
19 else: 19 else:
20 self.libraries = ['ssl', 'crypto'] 20 self.libraries = ['ssl', 'crypto']
21- self.openssl = '/usr' 21- self.openssl = '/usr'
@@ -23,7 +23,7 @@ Index: M2Crypto-0.23.0/setup.py
23 23
24 def finalize_options(self): 24 def finalize_options(self):
25 '''Overloaded build_ext implementation to append custom openssl 25 '''Overloaded build_ext implementation to append custom openssl
26@@ -75,8 +75,8 @@ class _M2CryptoBuildExt(build_ext.build_ 26@@ -143,8 +143,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
27 if _openssl and os.path.isdir(_openssl): 27 if _openssl and os.path.isdir(_openssl):
28 self.openssl = _openssl 28 self.openssl = _openssl
29 29
@@ -34,3 +34,6 @@ Index: M2Crypto-0.23.0/setup.py
34 34
35 if platform.system() == "Linux": 35 if platform.system() == "Linux":
36 if _multiarch: # on Fedora/RHEL it is an empty string 36 if _multiarch: # on Fedora/RHEL it is an empty string
37--
382.7.4
39