diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2024-08-09 11:52:31 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-09 14:25:30 -0700 |
commit | d7235d0abefaeb65c0f90bba7b66d811b11e056b (patch) | |
tree | 58ebda482e66ad4a12325a661273af9bb588b581 /meta-python/recipes-devtools/python | |
parent | 6f0a41130c0dcf80e22f6f3fd93d39369c235693 (diff) | |
download | meta-openembedded-d7235d0abefaeb65c0f90bba7b66d811b11e056b.tar.gz |
python3-itsdangerous: Upgrade 2.1.2 -> 2.2.0
Upgrade to release 2.2.0:
- Drop support for Python 3.7
- Use modern packaging metadata with pyproject.toml instead of
setup.cfg
- Use flit_core instead of setuptools as build backend
- Deprecate the __version__ attribute. Use feature detection, or
importlib.metadata.version("itsdangerous"), instead.
- Serializer and the return type of dumps is generic for type
checking. By default it is Serializer[str] and dumps returns a
str. If a different serializer argument is given, it will try to
infer the return type of its dumps method.
- The default hashlib.sha1 may not be available in FIPS builds.
Don't access it at import time so the developer has time to
change the default.
License-Update: Renamed from LICENSE.rst to LICENSE.txt
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-itsdangerous_2.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-itsdangerous_2.1.2.bb) | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-itsdangerous_2.1.2.bb b/meta-python/recipes-devtools/python/python3-itsdangerous_2.2.0.bb index 5af1d594b..f4d8d5296 100644 --- a/meta-python/recipes-devtools/python/python3-itsdangerous_2.1.2.bb +++ b/meta-python/recipes-devtools/python/python3-itsdangerous_2.2.0.bb | |||
@@ -1,11 +1,11 @@ | |||
1 | SUMMARY = "Various helpers to pass trusted data to untrusted environments and back." | 1 | SUMMARY = "Various helpers to pass trusted data to untrusted environments and back." |
2 | HOMEPAGE = "http://github.com/mitsuhiko/itsdangerous" | 2 | HOMEPAGE = "http://github.com/mitsuhiko/itsdangerous" |
3 | LICENSE = "BSD-3-Clause" | 3 | LICENSE = "BSD-3-Clause" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=4cda9a0ebd516714f360b0e9418cfb37" | 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4cda9a0ebd516714f360b0e9418cfb37" |
5 | 5 | ||
6 | SRC_URI[sha256sum] = "5dbbc68b317e5e42f327f9021763545dc3fc3bfe22e6deb96aaf1fc38874156a" | 6 | SRC_URI[sha256sum] = "e0050c0b7da1eea53ffaf149c0cfbb5c6e2e2b69c4bef22c81fa6eb73e5f6173" |
7 | 7 | ||
8 | inherit pypi setuptools3 | 8 | inherit pypi python_setuptools_build_meta |
9 | 9 | ||
10 | CLEANBROKEN = "1" | 10 | CLEANBROKEN = "1" |
11 | 11 | ||