summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorRoger Knecht <roger@norberthealth.com>2022-12-13 10:29:42 +0000
committerKhem Raj <raj.khem@gmail.com>2022-12-13 09:18:18 -0800
commitd50e9ebee015923a52f840724c292f3b663763b2 (patch)
treec852636aa534c244f7cb47d740e8d72314309463 /meta-python/recipes-devtools/python
parentc062df353c274fae782f9c03c62f9ce199efb9f0 (diff)
downloadmeta-openembedded-d50e9ebee015923a52f840724c292f3b663763b2.tar.gz
python3-rapidjson: add recipe
Add a recipe for the python bindings of the rapidjson library. Signed-off-by: Roger Knecht <roger@norberthealth.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
new file mode 100644
index 000000000..8b50aabb7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rapidjson_1.9.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Python wrapper around rapidjson"
2HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
6
7SRC_URI = "git://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master"
8SRCREV = "8f4ab8e197ca30c03726b675ae7cce6ac9d6622e"
9
10S = "${WORKDIR}/git"
11
12inherit setuptools3
13
14SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}"
15
16DEPENDS += " \
17 rapidjson \
18"
19
20RDEPENDS:${PN} += " \
21 ${PYTHON_PN}-core \
22"