summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:51 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commitcb3e4746dc3c1252cfb309326f89fcba06b6727f (patch)
treea424ae2a545aaaf3eabe313f4206763e91184a5c /meta-python/recipes-devtools/python
parent3692de1a1af1a919d99a2c6ef6b4c66e067f37b3 (diff)
downloadmeta-openembedded-cb3e4746dc3c1252cfb309326f89fcba06b6727f.tar.gz
python-scrypt: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-scrypt.inc29
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch (renamed from meta-python/recipes-devtools/python/python-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch)0
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb25
3 files changed, 23 insertions, 31 deletions
diff --git a/meta-python/recipes-devtools/python/python-scrypt.inc b/meta-python/recipes-devtools/python/python-scrypt.inc
deleted file mode 100644
index aa9d7b8d4..000000000
--- a/meta-python/recipes-devtools/python/python-scrypt.inc
+++ /dev/null
@@ -1,29 +0,0 @@
1DESCRIPTION = "Bindings for the scrypt key derivation function library"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc"
4HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-scrypt:"
7
8SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
9
10SRC_URI[md5sum] = "ae8e3263aa31b040c1f9c7f1e1843a56"
11SRC_URI[sha256sum] = "f8239b2d47fa1d40bc27efd231dc7083695d10c1c2ac51a99380360741e0362d"
12
13inherit pypi ptest
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS_${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS_${PN}_class-target += "\
29"
diff --git a/meta-python/recipes-devtools/python/python-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch b/meta-python/recipes-devtools/python/python3-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch
index d535e4326..d535e4326 100644
--- a/meta-python/recipes-devtools/python/python-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch
+++ b/meta-python/recipes-devtools/python/python3-scrypt/0001-py-scrypt-remove-the-hard-coded-include-paths.patch
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
index f49665322..7588fc54b 100644
--- a/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.6.bb
@@ -1,3 +1,24 @@
1inherit setuptools3 python3-dir 1DESCRIPTION = "Bindings for the scrypt key derivation function library"
2require python-scrypt.inc 2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=168ff75417f75a83e63c8875292d44dc"
4HOMEPAGE="https://bitbucket.org/mhallin/py-scrypt/overview"
3 5
6SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
7
8SRC_URI[md5sum] = "ae8e3263aa31b040c1f9c7f1e1843a56"
9SRC_URI[sha256sum] = "f8239b2d47fa1d40bc27efd231dc7083695d10c1c2ac51a99380360741e0362d"
10
11inherit pypi ptest setuptools3
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}