summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-16 19:11:37 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-17 01:09:18 -0700
commitc73fbd349ae3f2bbc921d036f230c1bc4567ac14 (patch)
treea01b98747eef281e890761f1d174d79c91281b22 /meta-python/recipes-devtools/python
parentc1a04594cb8aacebca1c16e0ad8e43f07e4817fd (diff)
downloadmeta-openembedded-c73fbd349ae3f2bbc921d036f230c1bc4567ac14.tar.gz
python3-grpcio-tools: Disable clang's musttail attribute on mips
mips backend is not able to handle it in clang-15 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch30
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools_1.48.1.bb4
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch
new file mode 100644
index 000000000..d19d1eee4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-protobuf-Disable-musttail-attribute-on-mips.patch
@@ -0,0 +1,30 @@
1From 64d737318656286f69ddc5ad654072785ddcbbed Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 16 Sep 2022 19:09:15 -0700
4Subject: [PATCH] protobuf: Disable musttail attribute on mips
5
6See https://github.com/llvm/llvm-project/issues/57795
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 third_party/protobuf/src/google/protobuf/port_def.inc | 3 ++-
12 1 file changed, 2 insertions(+), 1 deletion(-)
13
14diff --git a/third_party/protobuf/src/google/protobuf/port_def.inc b/third_party/protobuf/src/google/protobuf/port_def.inc
15index 37632cf..3c3c1e4 100644
16--- a/third_party/protobuf/src/google/protobuf/port_def.inc
17+++ b/third_party/protobuf/src/google/protobuf/port_def.inc
18@@ -230,7 +230,8 @@
19 #error PROTOBUF_TAILCALL was previously defined
20 #endif
21 #if __has_cpp_attribute(clang::musttail) && \
22- !defined(__arm__) && !defined(_ARCH_PPC) && !defined(__wasm__)
23+ !defined(__arm__) && !defined(_ARCH_PPC) && !defined(__wasm__) && \
24+ !defined(__mips__)
25 # ifndef PROTO2_OPENSOURCE
26 // Compilation fails on ARM32: b/195943306
27 // Compilation fails on powerpc64le: b/187985113
28--
292.37.3
30
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.48.1.bb b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.48.1.bb
index d295429ae..002211a8c 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.48.1.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.48.1.bb
@@ -9,7 +9,9 @@ inherit pypi setuptools3
9 9
10DEPENDS += "${PYTHON_PN}-grpcio" 10DEPENDS += "${PYTHON_PN}-grpcio"
11 11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" 12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
13 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \
14 "
13SRC_URI[sha256sum] = "1178f2ea531f80cc2027ec64728df6ffc8e98cf1df61652a496eafd612127183" 15SRC_URI[sha256sum] = "1178f2ea531f80cc2027ec64728df6ffc8e98cf1df61652a496eafd612127183"
14 16
15RDEPENDS:${PN} = "${PYTHON_PN}-grpcio" 17RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"