summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-08-01 15:41:53 +0800
committerKhem Raj <raj.khem@gmail.com>2023-08-01 08:46:48 -0700
commitbe496d5b03930e4a79eb82ba671b6cdc861df300 (patch)
tree620821ecd57cae81fe558b6f9ea3c3542b4e7de2 /meta-python/recipes-devtools/python
parenta8eb40a15083588420e533cf45fddc3f017af972 (diff)
downloadmeta-openembedded-be496d5b03930e4a79eb82ba671b6cdc861df300.tar.gz
python3-typeguard: upgrade 4.0.0 -> 4.1.0
Changelog: ========== - Added support for passing a tuple as expected_type to check_type(), making it more of a drop-in replacement for isinstance() - Fixed regression where Literal inside a Union had quotes stripped from its contents, thus typically causing NameError to be raised when run - Fixed handling of typing_extensions.Literal on Python 3.8 and 3.9 when typing_extensions>=4.6.0 is installed - Fixed NameError when generated type checking code references an imported name from a method - Fixed docstrings disappearing from instrumented functions - Fixed @typechecked failing to instrument functions when there are more than one function within the same scope - Fixed frozenset not being checked Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_4.1.0.bb (renamed from meta-python/recipes-devtools/python/python3-typeguard_4.0.0.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_4.0.0.bb b/meta-python/recipes-devtools/python/python3-typeguard_4.1.0.bb
index ca17e2b13..f64c70a72 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_4.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_4.1.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5 5
6SRC_URI[sha256sum] = "194fb3dbcb06ea9caf7088f3befee014de57961689f9c859ac5239b1ef61d987" 6SRC_URI[sha256sum] = "b05a54bb0276eefd28880df42e004a71e699c8081fcb9d0536b2ceb01019f60c"
7 7
8inherit pypi python_setuptools_build_meta ptest 8inherit pypi python_setuptools_build_meta ptest
9 9