diff options
author | Jagadeesh Krishnanjanappa <workjagadeesh@gmail.com> | 2022-08-23 17:26:00 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-08-23 19:12:52 -0700 |
commit | a3930e53deb587d506c56c7d52f1ba61255e20d3 (patch) | |
tree | d23aae8813ef239c35d7e3f71811edc106dbe212 /meta-python/recipes-devtools/python | |
parent | 980cdfd0138f7ef266094f373f5450e40e9b911f (diff) | |
download | meta-openembedded-a3930e53deb587d506c56c7d52f1ba61255e20d3.tar.gz |
python3-asgiref: add recipe
The default version of python3-django 2.2.x is no longer supported.
So, python3-django either 3.x or 4.x should be preferred, that
requires python3-asgiref at runtime.
More info at https://bugzilla.yoctoproject.org/show_bug.cgi?id=14888
Signed-off-by: Jagadeesh Krishnanjanappa <workjagadeesh@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-asgiref/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-asgiref_3.5.2.bb | 29 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asgiref/run-ptest b/meta-python/recipes-devtools/python/python3-asgiref/run-ptest new file mode 100644 index 000000000..3385d6893 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-asgiref/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | ||
diff --git a/meta-python/recipes-devtools/python/python3-asgiref_3.5.2.bb b/meta-python/recipes-devtools/python/python3-asgiref_3.5.2.bb new file mode 100644 index 000000000..860479199 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-asgiref_3.5.2.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "ASGI is a standard for Python asynchronous web apps and servers to communicate with each other, and positioned as an asynchronous successor to WSGI." | ||
2 | HOMEPAGE = "https://pypi.org/project/asgiref/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa" | ||
6 | |||
7 | SRC_URI += "file://run-ptest \ | ||
8 | " | ||
9 | |||
10 | SRC_URI[sha256sum] = "4a29362a6acebe09bf1d6640db38c1dc3d9217c68e6f9f6204d72667fc19a424" | ||
11 | |||
12 | export BUILD_SYS | ||
13 | export HOST_SYS | ||
14 | |||
15 | inherit pypi ptest setuptools3 | ||
16 | |||
17 | RDEPENDS:${PN}-ptest += " \ | ||
18 | ${PYTHON_PN}-pytest \ | ||
19 | ${PYTHON_PN}-asyncio \ | ||
20 | ${PYTHON_PN}-io \ | ||
21 | ${PYTHON_PN}-multiprocessing \ | ||
22 | " | ||
23 | |||
24 | do_install_ptest() { | ||
25 | install -d ${D}${PTEST_PATH}/tests | ||
26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
27 | } | ||
28 | |||
29 | BBCLASSEXTEND = "native nativesdk" | ||