summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorBartosz Golaszewski <bartosz.golaszewski@linaro.org>2023-05-31 10:22:22 +0200
committerKhem Raj <raj.khem@gmail.com>2023-06-06 23:07:58 -0700
commit99a83d698178d3555111005d69f934195688c1f5 (patch)
treec09c573ce31c58739196b0c4fe48a16e4f2ada4c /meta-python/recipes-devtools/python
parent789f44c3ff11b9b47330ea8817d289843bab7fc9 (diff)
downloadmeta-openembedded-99a83d698178d3555111005d69f934195688c1f5.tar.gz
python3-parse: don't use PYTHON_PN and improve coding style
We no longer support python2. Drop PYTHON_PN and use python3 explicitly. While at it: make indentation consistent. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-parse_1.19.0.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb b/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb
index 2bf55cbaf..8db482e14 100644
--- a/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb
+++ b/meta-python/recipes-devtools/python/python3-parse_1.19.0.bb
@@ -8,18 +8,18 @@ SRC_URI[sha256sum] = "9ff82852bcb65d139813e2a5197627a94966245c897796760a3a2a8eb6
8inherit pypi setuptools3 ptest 8inherit pypi setuptools3 ptest
9 9
10RDEPENDS:${PN} += "\ 10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-datetime \ 11 python3-datetime \
12 ${PYTHON_PN}-logging \ 12 python3-logging \
13 " 13"
14 14
15SRC_URI += " \ 15SRC_URI += " \
16 file://run-ptest \ 16 file://run-ptest \
17" 17"
18 18
19RDEPENDS:${PN}-ptest += " \ 19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \ 20 python3-pytest \
21" 21"
22 22
23do_install_ptest() { 23do_install_ptest() {
24 cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/ 24 cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
25} 25}