summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorBartosz Golaszewski <bartosz.golaszewski@linaro.org>2023-05-31 10:22:56 +0200
committerKhem Raj <raj.khem@gmail.com>2023-06-06 23:07:58 -0700
commit8a0dbc0c537d94f082abd595efcbcf254e86d842 (patch)
tree42d420ee8916171c4961e2b4809d55e415f96e0e /meta-python/recipes-devtools/python
parent54f5b0087a86ad953d30931ff927d1e0330d580a (diff)
downloadmeta-openembedded-8a0dbc0c537d94f082abd595efcbcf254e86d842.tar.gz
python3-xlrd: fix coding style
Put RDEPENDS on separate lines, don't use PYTHON_PN. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
index da0dc2671..03c18e545 100644
--- a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
@@ -20,10 +20,15 @@ inherit ptest setuptools3
20PIP_INSTALL_PACKAGE = "xlrd" 20PIP_INSTALL_PACKAGE = "xlrd"
21PIP_INSTALL_DIST_PATH = "${S}/dist" 21PIP_INSTALL_DIST_PATH = "${S}/dist"
22 22
23RDEPENDS:${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell" 23RDEPENDS:${PN} += " \
24 python3-compression \
25 python3-io \
26 python3-pprint \
27 python3-shell \
28"
24 29
25RDEPENDS:${PN}-ptest += " \ 30RDEPENDS:${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \ 31 python3-pytest \
27" 32"
28 33
29do_install_ptest() { 34do_install_ptest() {