summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-04 20:49:36 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-04 20:52:52 -0700
commit7efd67bcafd0d714c22b16b890cc99f10ec7a3f9 (patch)
tree23cd89f5ebc7f6334413f36d4eb1f8dbddd7086a /meta-python/recipes-devtools/python
parent677de1dc3379323e18e3dc2ec2bbe0a4fef47b9a (diff)
downloadmeta-openembedded-7efd67bcafd0d714c22b16b890cc99f10ec7a3f9.tar.gz
python3-pyzmq: Fix ptests
Add missing dependency on tornado, its also flagged by some ptests {'python3-pyzmq': ['tests/test_ioloop.py:test_ioloop', 'tests/test_ioloop.py:test_ioloop_install']} Skip ptests which cause zeromq errors Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb1
2 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest b/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
index 8d2017d39..beefefa66 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pyzmq/run-ptest
@@ -1,3 +1,4 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest --automake 3pytest --automake \
4-k 'not test_callable_check and not test_on_recv_basic and not test_on_recv_wake and not test_on_recv_async and not test_on_recv_async_error and not test_curve'
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb b/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
index ca602d250..540aa6200 100644
--- a/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyzmq_25.1.2.bb
@@ -28,6 +28,7 @@ FILES:${PN}-test += "\
28RDEPENDS:${PN} += "\ 28RDEPENDS:${PN} += "\
29 python3-json \ 29 python3-json \
30 python3-multiprocessing \ 30 python3-multiprocessing \
31 python3-tornado \
31" 32"
32 33
33RDEPENDS:${PN}-ptest += "\ 34RDEPENDS:${PN}-ptest += "\