summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-06 20:17:40 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:24 -0800
commit442b986b87a31f9d0bf0f1583b1846f664c08706 (patch)
tree520418c5caf085778332a97f0b39ea463add808c /meta-python/recipes-devtools/python
parent29a287046e8200a8f9e5cb9c91f47feb7ceeebd1 (diff)
downloadmeta-openembedded-442b986b87a31f9d0bf0f1583b1846f664c08706.tar.gz
python3-icecream: add recipe
icecream (ic) package offers a more concise and readable way to debug code by replacing print statements with simple function calls. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb b/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb
new file mode 100644
index 000000000..ec3a4b90f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Never use print() to debug again; inspect variables, expressions, and program execution with a single, simple function call."
2HOMEPAGE = "https://github.com/gruns/icecream"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eca5ce1610d64ed40920efdce85ff8d1"
5
6SRC_URI[sha256sum] = "0aa4a7c3374ec36153a1d08f81e3080e83d8ac1eefd97d2f4fe9544e8f9b49de"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += " \
11 python3-asttokens \
12 python3-colorama \
13 python3-executing \
14 python3-numbers \
15 python3-pygments \
16 python3-pprint \
17"