summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-08-17 18:35:38 +0300
committerKhem Raj <raj.khem@gmail.com>2022-08-17 09:35:42 -0700
commit26057707452352ac9b4a2cf52f240a27ca72cb27 (patch)
tree7cff43de85d0106e3c129944e8cd945f339d0de1 /meta-python/recipes-devtools/python
parent330b46745ccf09ea190ebbea52003876698ce9da (diff)
downloadmeta-openembedded-26057707452352ac9b4a2cf52f240a27ca72cb27.tar.gz
python3-term: Upgrade 2.3 -> 2.4
Upgrade to release 2.4: - Add Python 3.8-3.10 to tox.ini. Remove old Python versions. - Replace deprecated python setup.py test in tox.ini. - Remove deprecated test_suite from setup.py. - Move metadata to setup.cfg and add a pyproject.toml file. - Include tests in sdist but not in wheel. - Fix escape sequence warning in byte string literal. - Open /dev/tty in binary mode under both Python 2 and 3. - Officially change opentty's bufsize argument default from 1 to -1. Under Python 3, 1 has effectively meant -1 all along but Python 3.8 now issues a warning. - Add readto, getfgcolor, getbgcolor, islightmode, and isdarkmode. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-term_2.4.bb (renamed from meta-python/recipes-devtools/python/python3-term_2.3.bb)9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-term_2.3.bb b/meta-python/recipes-devtools/python/python3-term_2.4.bb
index 6b62eb02c..bc6a4c3df 100644
--- a/meta-python/recipes-devtools/python/python3-term_2.3.bb
+++ b/meta-python/recipes-devtools/python/python3-term_2.4.bb
@@ -3,9 +3,10 @@ SECTION = "devel/python"
3LICENSE = "Python-2.0" 3LICENSE = "Python-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d90e2d280a4836c607520383d1639be1" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=d90e2d280a4836c607520383d1639be1"
5 5
6SRC_URI[md5sum] = "ab0c1bce381b1109fe4390c56aa06237" 6SRC_URI[sha256sum] = "2cca4cf5f83035ca12627c4bbeff2891ad4711666247a790fd8200d73f38c3f0"
7SRC_URI[sha256sum] = "3dcc8c212e04700784e5c1c5b601916ba0549ae6025b35b64fd62144899e7180"
8
9PYPI_PACKAGE_EXT = "zip"
10 7
11inherit pypi setuptools3 8inherit pypi setuptools3
9
10RDEPENDS:${PN} = "\
11 ${PYTHON_PN}-io \
12"