summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-08 15:14:09 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:44:06 -0700
commit14c04f49751ed6490a47a009a9851690dae4c85b (patch)
tree6ca3d491f1383c2b04383668dea46fb11e204a26 /meta-python/recipes-devtools/python
parentb70c432f969b59c6aaaddb311fe1f18dec006f8b (diff)
downloadmeta-openembedded-14c04f49751ed6490a47a009a9851690dae4c85b.tar.gz
python3-progress: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-progress.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-progress_1.5.bb16
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-progress.inc b/meta-python/recipes-devtools/python/python-progress.inc
deleted file mode 100644
index d59ba2cc5..000000000
--- a/meta-python/recipes-devtools/python/python-progress.inc
+++ /dev/null
@@ -1,14 +0,0 @@
1SUMMARY = "Easy progress reporting for Python"
2HOMEPAGE = "http://github.com/verigak/progress/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=aef5566ac4fede9815eccf124c281317"
5
6SRC_URI[md5sum] = "408df0e3db0ad4b74f19f6beec814ae4"
7SRC_URI[sha256sum] = "69ecedd1d1bbe71bf6313d88d1e6c4d2957b7f1d4f71312c211257f7dae64372"
8
9RDEPENDS_${PN}_class-target += " \
10 ${PYTHON_PN}-datetime \
11 ${PYTHON_PN}-math \
12"
13
14BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-progress_1.5.bb b/meta-python/recipes-devtools/python/python3-progress_1.5.bb
index 45e264213..1f299dbed 100644
--- a/meta-python/recipes-devtools/python/python3-progress_1.5.bb
+++ b/meta-python/recipes-devtools/python/python3-progress_1.5.bb
@@ -1,2 +1,16 @@
1SUMMARY = "Easy progress reporting for Python"
2HOMEPAGE = "http://github.com/verigak/progress/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=aef5566ac4fede9815eccf124c281317"
5
6SRC_URI[md5sum] = "408df0e3db0ad4b74f19f6beec814ae4"
7SRC_URI[sha256sum] = "69ecedd1d1bbe71bf6313d88d1e6c4d2957b7f1d4f71312c211257f7dae64372"
8
1inherit pypi setuptools3 9inherit pypi setuptools3
2require python-progress.inc 10
11RDEPENDS_${PN}_class-target += " \
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-math \
14"
15
16BBCLASSEXTEND = "native nativesdk"