diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-06-29 15:12:31 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-30 07:50:44 -0700 |
commit | 6ba3dfb344b30240294323b76243dd0f85e986d0 (patch) | |
tree | 0703fcb5b34c2796ce2d7ca795cff2df72e5debe /meta-python/recipes-devtools/python/python3-yappi_1.2.5.bb | |
parent | 319c7562ced2b9ca77ec01471c8d81242c071b41 (diff) | |
download | meta-openembedded-6ba3dfb344b30240294323b76243dd0f85e986d0.tar.gz |
python3-yappi: Upgrade 1.0 -> 1.2.5
Fix HOMEPAGE. Use file LICENSE for LIC_FILES_CHKSUM. Upgrade
to release 1.2.5:
- Fix tag/ctx_id filtering on get_func_stats
- Add filter_callback to get_func_stats() for filtering
function/module descriptors
- FIX: issues related to invalid conversion from long->ptr in
Win32
- Optimize tstate->dict retrieval
- Various other fixes
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-yappi_1.2.5.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-yappi_1.2.5.bb | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-yappi_1.2.5.bb b/meta-python/recipes-devtools/python/python3-yappi_1.2.5.bb new file mode 100644 index 000000000..366dec3dc --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-yappi_1.2.5.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "Yet Another Python Profiler" | ||
2 | HOMEPAGE = "https://github.com/sumerc/yappi" | ||
3 | |||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee" | ||
6 | |||
7 | SRC_URI[md5sum] = "83237494e7d22df2a31935a1e6650fa6" | ||
8 | SRC_URI[sha256sum] = "ad5fa4caf2859e480ffc4ec3e85615a6f7dea852c8f035f2db723f824ed4ba11" | ||
9 | |||
10 | SRC_URI += " \ | ||
11 | file://run-ptest \ | ||
12 | " | ||
13 | |||
14 | inherit pypi setuptools3 ptest | ||
15 | |||
16 | RDEPENDS_${PN} += "\ | ||
17 | ${PYTHON_PN}-datetime \ | ||
18 | ${PYTHON_PN}-pickle \ | ||
19 | ${PYTHON_PN}-threading \ | ||
20 | " | ||
21 | |||
22 | RDEPENDS_${PN}-ptest += " \ | ||
23 | ${PYTHON_PN}-pytest \ | ||
24 | ${PYTHON_PN}-multiprocessing \ | ||
25 | ${PYTHON_PN}-profile \ | ||
26 | " | ||
27 | |||
28 | do_install_ptest() { | ||
29 | install -d ${D}${PTEST_PATH}/tests | ||
30 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
31 | cp -f ${S}/yappi/yappi.py ${D}/${PTEST_PATH}/ | ||
32 | } | ||