diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-01-28 12:29:03 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-01 10:44:27 -0800 |
commit | 0532eaf50b33446ebb2feb7d4d56184a9681b990 (patch) | |
tree | 2c39ac0592c605abada870c667c10305cc5ffdd9 /meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb | |
parent | 82b80e6ab10a0cf678428ff11832dc9b90f9d5a6 (diff) | |
download | meta-openembedded-0532eaf50b33446ebb2feb7d4d56184a9681b990.tar.gz |
python3-xlrd: Upgrade 1.2.0 -> 2.0.1
Upgrade to release 2.0.1:
- Use the README as the long description on PyPI.
- Remove support for anything other than .xls files.
- Remove support for psyco.
- Change the default encoding used when no CODEPAGE record can be
found from ascii to iso-8859-1.
- Add support for iterating over :class:`~xlrd.book.Book` objects.
- Add support for item access from :class:`~xlrd.book.Book`
objects, where integer indices and string sheet names are
supported.
- Non-unicode spaces are now stripped from the "last author"
information.
- Workbook corruption errors can now be ignored using the
ignore_workbook_corruption option to :class:`~xlrd.open_workbook`.
- Handle WRITEACCESS records with invalid trailing characters.
- Officially support Python 3.8 and 3.9.
Get the source code from the git repository rather than from PyPI
to obtain the tests.
License-Update: Use file LICENSE.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb | 31 |
1 files changed, 0 insertions, 31 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb b/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb deleted file mode 100644 index 571dba6fa..000000000 --- a/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | SUMMARY = "Library for developers to extract data from Microsoft Excel (tm) spreadsheet files" | ||
2 | DESCRIPTION = "Extract data from Excel spreadsheets (.xls and .xlsx,\ | ||
3 | versions 2.0 onwards) on any platform. Pure Python (2.6, 2.7, 3.2+). \ | ||
4 | Strong support for Excel dates. Unicode-aware." | ||
5 | HOMEPAGE = "http://www.python-excel.org/" | ||
6 | LICENSE = "BSD-3-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5f4244d51fcc1e7cc2d43e96891b2f80" | ||
8 | |||
9 | SRC_URI[md5sum] = "e5d5b96924d791b22898b622eb3e918e" | ||
10 | SRC_URI[sha256sum] = "546eb36cee8db40c3eaa46c351e67ffee6eeb5fa2650b71bc4c758a29a1b29b2" | ||
11 | |||
12 | SRC_URI += " \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | inherit ptest pypi setuptools3 | ||
17 | |||
18 | RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell" | ||
19 | |||
20 | RDEPENDS_${PN}-ptest += " \ | ||
21 | ${PYTHON_PN}-pytest \ | ||
22 | " | ||
23 | |||
24 | do_install_ptest() { | ||
25 | install -d ${D}${PTEST_PATH}/tests | ||
26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
27 | install -d ${D}${PTEST_PATH}/examples | ||
28 | cp -rf ${S}/examples/* ${D}${PTEST_PATH}/examples/ | ||
29 | } | ||
30 | |||
31 | BBCLASSEXTEND = "native nativesdk" | ||