summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-05-28 09:48:12 +0800
committerKhem Raj <raj.khem@gmail.com>2024-05-28 09:34:35 -0700
commit66cb9007b0bb20e45279b8f992cdcca96e227b0a (patch)
treea7d76a1721b9ddf649ce4449c51fb27cdd44806a /meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb
parent868ba2a93263d6feca431cc0800acc4747b58454 (diff)
downloadmeta-openembedded-66cb9007b0bb20e45279b8f992cdcca96e227b0a.tar.gz
python3-ujson: upgrade 5.9.0 -> 5.10.0
Changelog: Add support for Python 3.13 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb b/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb
new file mode 100644
index 0000000000..c64c800626
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ujson_5.10.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e0039a83d8a99726b5418f0b03302d0a"
6
7SRC_URI[sha256sum] = "b3cd8f3c5d8c7738257f1018880444f7b7d9b66232c64649f562d7ba86ad4bc1"
8
9inherit pypi ptest setuptools3
10
11SRC_URI += " \
12 file://run-ptest \
13 file://0001-setup.py-Do-not-strip-debugging-symbols.patch \
14"
15
16DEPENDS += "python3-setuptools-scm-native"
17
18RDEPENDS:${PN} += "\
19 python3-datetime \
20 python3-numbers \
21"
22
23RDEPENDS:${PN}-ptest += " \
24 python3-json \
25 python3-pytest \
26 python3-pytz \
27 python3-unittest-automake-output \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33}
34
35BBCLASSEXTEND = "native nativesdk"