summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-transitions_0.8.6.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-07 00:06:57 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-08 08:42:15 -0800
commit7dde75fdf04e5f6c7fa2b8531c6f02b5a3c49e7c (patch)
tree732fcc398bdaf2493c37aeacfb16946a4578c660 /meta-python/recipes-devtools/python/python3-transitions_0.8.6.bb
parentd191a87770b0b35d3a08b4cd634a35810923e3c9 (diff)
downloadmeta-openembedded-7dde75fdf04e5f6c7fa2b8531c6f02b5a3c49e7c.tar.gz
python3-transitions: Upgrade 0.8.5 -> 0.8.6
Upgrade to release 0.8.6: - HierarchicalMachine.add_states will raise a ValueError when an Enum name contains the currently used NestedState.separator. - Bugfix: Reset NestedState._scope when enter/exit callbacks raise an exception - Bugfix: Let HierarchicalMachine._get_trigger which is bound to model.trigger raise a MachineError for invalid events and AttributeError for unknown events - Introduced HierarchicalMachine.has_trigger to determine whether an event is valid for an HSM - Feature: AsyncMachine features an event queue dictionary for individual models when queued='model' - Feature: Machine.remove_model will now also remove model events from the event queue when queued=True - Feature: Machine.get_transitions and its HSM counterpart now accept Enum and State for source and dest License-Update: Update year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-transitions_0.8.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-transitions_0.8.6.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-transitions_0.8.6.bb b/meta-python/recipes-devtools/python/python3-transitions_0.8.6.bb
new file mode 100644
index 000000000..701c82cda
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-transitions_0.8.6.bb
@@ -0,0 +1,9 @@
1SUMMARY = "A lightweight, object-oriented Python state machine implementation with many extensions."
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=baac7be1f4c17620df74188e23da6d47"
4
5inherit pypi setuptools3
6
7SRC_URI[sha256sum] = "032e10113139852ffb3ecfa4c2a5138f87441d85c3d6ad9122bb4b0978180a8d"
8
9RDEPENDS_${PN} += "python3-six"