summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-traitlets_5.14.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-19 14:24:12 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-19 14:33:13 -0700
commita85d23b314910da1dd67b35a99aa5de2ef38ae61 (patch)
tree4657aa0e7e59827eb6d789007a4637e50f59944c /meta-python/recipes-devtools/python/python3-traitlets_5.14.3.bb
parent0ef3e9918dcee702a0e4edbaa863161bb2ac7821 (diff)
downloadmeta-openembedded-a85d23b314910da1dd67b35a99aa5de2ef38ae61.tar.gz
python3-traitlets: Upgrade to 5.14.3
Bring https://github.com/ipython/traitlets/pull/903 on top of 5.14.2 release Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-traitlets_5.14.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-traitlets_5.14.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-traitlets_5.14.3.bb b/meta-python/recipes-devtools/python/python3-traitlets_5.14.3.bb
new file mode 100644
index 000000000..5142e92a0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-traitlets_5.14.3.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Traitlets Python config system"
2HOMEPAGE = "https://github.com/ipython/traitlets"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=13bed0ee6f46a6f6dbf1f9f9572f250a"
5
6SRC_URI[sha256sum] = "9ed0579d3502c94b4b3732ac120375cda96f923114522847de4b3bb98b96b6b7"
7
8inherit pypi python_hatchling ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 python3-argcomplete \
16 bash \
17 python3-mypy \
18 python3-pytest \
19 python3-pytest-mock \
20 python3-unittest-automake-output \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}