summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-07-17 03:43:17 +0800
committerKhem Raj <raj.khem@gmail.com>2020-07-16 12:10:32 -0700
commit0fdee019fd5c90abd057b9c47f6a6d6786caec5c (patch)
tree15d61a15bcc6f823d82105181c55307355b2594e /meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
parentab11bdfe0513579098553f8dd9569f8a6b39850a (diff)
downloadmeta-openembedded-0fdee019fd5c90abd057b9c47f6a6d6786caec5c.tar.gz
python3-semver: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-semver_2.10.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-semver_2.10.2.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb b/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
index b41ef5ddc..71cb1acec 100644
--- a/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
+++ b/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
@@ -7,6 +7,18 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665
7SRC_URI[md5sum] = "3e11ae9782121e8ffe9f8a8b763a8cb5" 7SRC_URI[md5sum] = "3e11ae9782121e8ffe9f8a8b763a8cb5"
8SRC_URI[sha256sum] = "c0a4a9d1e45557297a722ee9bac3de2ec2ea79016b6ffcaca609b0bc62cf4276" 8SRC_URI[sha256sum] = "c0a4a9d1e45557297a722ee9bac3de2ec2ea79016b6ffcaca609b0bc62cf4276"
9 9
10inherit pypi setuptools3 10inherit pypi setuptools3 ptest
11 11
12BBCLASSEXTEND = "native nativesdk" 12BBCLASSEXTEND = "native nativesdk"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS_${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
20"
21
22do_install_ptest() {
23 cp -f ${S}/test_semver.py ${D}${PTEST_PATH}/
24}