summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-10-14 16:55:00 +0800
committerKhem Raj <raj.khem@gmail.com>2024-10-14 09:52:30 -0700
commit9203166fe1a7b12b31fcc60ed80535e0533e9653 (patch)
tree9951a2bd5186c74d64be50a71fc3d4da684549c6 /meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb
parentacb908fca17fc35e684a207059cccc03ae558434 (diff)
downloadmeta-openembedded-9203166fe1a7b12b31fcc60ed80535e0533e9653.tar.gz
python3-scrypt: upgrade 0.8.24 -> 0.8.27
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb
new file mode 100644
index 0000000000..a3254de07d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Bindings for the scrypt key derivation function library"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=05b5ac2824a7ae7489193b0f6a6f2cd1"
4HOMEPAGE="https://github.com/holgern/py-scrypt"
5
6SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
7
8SRC_URI[sha256sum] = "a7b637848ed518c1ea2b31a9ecaaa3f49616598d8442de8706cf1f01fbabf0a7"
9
10inherit pypi ptest setuptools3 dos2unix
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 python3-pytest \
18 python3-unittest-automake-output \
19"
20
21RDEPENDS:${PN} += " \
22 python3-ctypes \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/
28}