summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-03-07 19:49:01 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-09 07:37:04 -0800
commita3b2e752857ff6d474166892fe5c1737cdd1b061 (patch)
tree7068b62766138fbd12237d710bf796814942d7a2 /meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb
parentd59e7d90de89c3f025e3d9400319cb322cac8239 (diff)
downloadmeta-openembedded-a3b2e752857ff6d474166892fe5c1737cdd1b061.tar.gz
python3-scrypt: upgrade 0.8.19 -> 0.8.20
Changelog: ========= Fix #8 by adding missing gettimeofday.c to MANIFEST.in Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb
new file mode 100644
index 000000000..c38693268
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Bindings for the scrypt key derivation function library"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=05b5ac2824a7ae7489193b0f6a6f2cd1"
4HOMEPAGE="https://github.com/holgern/py-scrypt"
5
6SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
7
8SRC_URI[sha256sum] = "0d226c1c6744fb2e308b391410669b1df5cfe82637ffcb5ed489bf82b2d2eb78"
9
10inherit pypi ptest setuptools3 dos2unix
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20RDEPENDS:${PN} += " \
21 ${PYTHON_PN}-ctypes \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/
27}