summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-25 12:07:14 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-26 08:56:18 -0700
commit465426ebce5bcc5f6541e3fcc91cc5e8b2b8976b (patch)
tree6f4b0fab27da48fff7f9fafc32e7714c705d1788 /meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb
parentfa3e364a518778cfa6ef41d36612e744481882bc (diff)
downloadmeta-openembedded-465426ebce5bcc5f6541e3fcc91cc5e8b2b8976b.tar.gz
python3-ruamel-yaml: Upgrade 0.16.5 0> 0.16.10
Upgrade to release 0.16.10: - updated image references in README to sourceforge - update requirements so that ruamel.yaml.clib is installed for 3.8, as it has become available - fix typchecking issue on TaggedScalar - fix error in dumping literal scalar in sequence with comments before element - fix empty string mapping key roundtripping with preservation of quotes as `? ''` - fix incorrect state setting in class constructor - adjust deprecation warning test for Hashable, as that no longer warns The year in LICENSE has been updated and LIC_FILES_CHKSUM changed. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb16
1 files changed, 0 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb
deleted file mode 100644
index ba095648f..000000000
--- a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.5.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2AUTHOR = "Anthon van der Neut"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=caf8bd842440b537c044e131785a4666"
6
7PYPI_PACKAGE = "ruamel.yaml"
8
9inherit pypi setuptools3
10
11SRC_URI[md5sum] = "7d5a5b0a7621a1247b081cc8e4978354"
12SRC_URI[sha256sum] = "412a6f5cfdc0525dee6a27c08f5415c7fd832a7afcb7a0ed7319628aed23d408"
13
14do_install_prepend() {
15 export RUAMEL_NO_PIP_INSTALL_CHECK=1
16}