summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-robotframework_3.2.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-02 11:33:40 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-05 13:03:48 -0700
commit23eb584c6e494cca720dcdb03b9d0b02ace6a083 (patch)
treea4dbbb17e43f63368cbb4e6462b14c7b18d0c377 /meta-python/recipes-devtools/python/python3-robotframework_3.2.2.bb
parent46712eeb7113292f32d303ea50e6d7d376116692 (diff)
downloadmeta-openembedded-23eb584c6e494cca720dcdb03b9d0b02ace6a083.tar.gz
python3-robotframework: Upgrade 3.2.1 -> 3.2.2
Upgrade to release 3.2.2, a new minor release with some bug fixes, Libdoc enhancements and official Python 3.9 support. For more details please visit: https://github.com/robotframework/robotframework/blob/master/doc/releasenotes/rf-3.2.2.rst Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-robotframework_3.2.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework_3.2.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_3.2.2.bb b/meta-python/recipes-devtools/python/python3-robotframework_3.2.2.bb
new file mode 100644
index 000000000..10f031c7b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-robotframework_3.2.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "A Python generic test automation framework"
2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi setuptools3
13
14PYPI_PACKAGE_EXT = "zip"
15SRC_URI[md5sum] = "ac6b77c223821856e8ac077acf5a7c1d"
16SRC_URI[sha256sum] = "a0786a916d0572bd9d6afe26e95c6021e3df5dcafa0ece6b302e36366e58c24e"
17
18RDEPENDS_${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-pprint \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-difflib \
23 ${PYTHON_PN}-threading \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-docutils \
26 ${PYTHON_PN}-ctypes \
27"