summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
diff options
context:
space:
mode:
authorJasper Orschulko <jasper@fancydomain.eu>2023-06-25 23:39:57 +0200
committerKhem Raj <raj.khem@gmail.com>2023-06-26 05:12:55 -0700
commitfcdd12028b140808fcac55c41c18acb302faa8b9 (patch)
tree49b4fc256fe7016f77f9f42d9f8d4a5f2731ec8f /meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
parent18bb7ad88442e7a35144750c035472d498021243 (diff)
downloadmeta-openembedded-fcdd12028b140808fcac55c41c18acb302faa8b9.tar.gz
python3-pytest-cov: Add initial recipe 4.1.0
Dependency for python3-platformdirs 3.6.0 ptest Signed-off-by: Jasper Orschulko <jasper@fancydomain.eu> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
new file mode 100644
index 000000000..1ff3e75cb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
@@ -0,0 +1,14 @@
1SUMMARY = "Pytest plugin for measuring coverage."
2HOMEPAGE = "https://github.com/pytest-dev/pytest-cov"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = " \
5 file://LICENSE;md5=cbc4e25353c748c817db2daffe605e43 \
6"
7
8SRC_URI[sha256sum] = "3904b13dfbfec47f003b8e77fd5b589cd11904a21ddf1ab38a64f204d6a10ef6"
9
10inherit pypi setuptools3
11
12DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
13
14BBCLASSEXTEND = "native nativesdk"