summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyrad
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-07-14 13:44:00 +0100
committerKhem Raj <raj.khem@gmail.com>2022-07-15 12:48:34 -0400
commitca039757994cd6643b63c70cd85145eb98331e2a (patch)
treef3845399a93ad0055af6950deb84d0b4dd89fc95 /meta-python/recipes-devtools/python/python3-pyrad
parenta2cd474a57301ea50c2b7dc921ba678c96d35d45 (diff)
downloadmeta-openembedded-ca039757994cd6643b63c70cd85145eb98331e2a.tar.gz
python3-pyrad: fix build system specification
The upstream pyproject.toml says it needs to be built with the Poetry frontend, but that's deprecated behaviour and it should use the Poetry Core API instead. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyrad')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch b/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch
new file mode 100644
index 000000000..43a177da0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch
@@ -0,0 +1,26 @@
1Upstream-Status: Backport [https://github.com/pyradius/pyrad/commit/ffe182a44909e8f8278fb3e2ea052ddc097b48b9]
2Signed-off-by: Ross Burton <ross.burton@arm.com>
3
4From a4b70067dd6269e14a2f9530d820390a8a454231 Mon Sep 17 00:00:00 2001
5From: Martin Weinelt <hexa@darmstadt.ccc.de>
6Date: Thu, 14 Apr 2022 22:07:37 +0200
7Subject: [PATCH] Use poetry-core for pyproject based builds
8
9https://github.com/python-poetry/poetry-core#why-is-this-required
10---
11 pyproject.toml | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/pyproject.toml b/pyproject.toml
15index 87b1df3..711c52f 100755
16--- a/pyproject.toml
17+++ b/pyproject.toml
18@@ -1,6 +1,6 @@
19 [build-system]
20-requires = ["poetry>=1.0"]
21-build-backend = "poetry.masonry.api"
22+requires = ["poetry-core>=1.0.0"]
23+build-backend = "poetry.core.masonry.api"
24
25 [tool.poetry]
26 name = "pyrad"