diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-07-22 13:48:59 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-07-23 10:26:43 -0700 |
commit | 8b27915e26980588baca95d8048b9ba8beaad182 (patch) | |
tree | 0e5e47b208a7e44a4cabb093964fad50141794b6 /meta-python/recipes-devtools/python/python3-pymysql_0.10.0.bb | |
parent | 76103526779b532486cce403b4712bfb609a022f (diff) | |
download | meta-openembedded-8b27915e26980588baca95d8048b9ba8beaad182.tar.gz |
python3-pymysql: Upgrade 0.9.3 -> 0.10.0
Upgrade to release 0.10.0:
- MariaDB ed25519 auth is supported.
- Python 3.4 support is dropped.
- Context manager interface is removed from Connection. It will
be added with different meaning.
- MySQL warnings are not shown by default because many user report
issue to PyMySQL issue tracker when they see warning. You need
to call "SHOW WARNINGS" explicitly when you want to see warnings.
- Formatting of float object is changed from "3.14" to "3.14e0".
- Use cp1252 codec for latin1 charset.
- Fix decimal literal.
- TRUNCATED_WRONG_VALUE_FOR_FIELD, and ILLEGAL_VALUE_FOR_TYPE are
now DataError instead of InternalError.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymysql_0.10.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pymysql_0.10.0.bb | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymysql_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pymysql_0.10.0.bb new file mode 100644 index 000000000..895c47b03 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pymysql_0.10.0.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "A pure-Python MySQL client library" | ||
2 | DESCRIPTION = " \ | ||
3 | This package contains a pure-Python MySQL client library, based on PEP 249 \ | ||
4 | Most public APIs are compatible with mysqlclient and MySQLdb. \ | ||
5 | " | ||
6 | SECTION = "devel/python" | ||
7 | HOMEPAGE = "https://pymysql.readthedocs.io" | ||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc" | ||
10 | |||
11 | SRC_URI[md5sum] = "d08058b1592724d5808c43f56050f245" | ||
12 | SRC_URI[sha256sum] = "e14070bc84e050e0f80bf6063e31d276f03a0bb4d46b9eca2854566c4ae19837" | ||
13 | |||
14 | PYPI_PACKAGE = "PyMySQL" | ||
15 | inherit pypi setuptools3 | ||
16 | |||
17 | RDEPENDS_${PN} += "${PYTHON_PN}-cryptography" | ||