summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymodbus_3.6.8.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-05-02 10:48:15 -0400
committerKhem Raj <raj.khem@gmail.com>2024-05-02 07:32:51 -0700
commitba9c2a8d06545ea7a7cba03ed77273d59a764947 (patch)
tree2dcaeb9da0bd9bd04c8edd6203d1694a1b33d894 /meta-python/recipes-devtools/python/python3-pymodbus_3.6.8.bb
parent6112eb064ccaf7b9c74b285e3fc070bab0343340 (diff)
downloadmeta-openembedded-ba9c2a8d06545ea7a7cba03ed77273d59a764947.tar.gz
python3-pymodbus: upgrade 3.6.7 -> 3.6.8
Changelog: Allow socket exception response with wrong length Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymodbus_3.6.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymodbus_3.6.8.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymodbus_3.6.8.bb b/meta-python/recipes-devtools/python/python3-pymodbus_3.6.8.bb
new file mode 100644
index 000000000..b94504f14
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymodbus_3.6.8.bb
@@ -0,0 +1,31 @@
1SUMMARY = "A fully featured modbus protocol stack in python"
2HOMEPAGE = "https://github.com/riptideio/pymodbus/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=eba8057aa82c058d2042b4b0a0e9cc63"
5
6SRC_URI[sha256sum] = "abb214716b56fc62bc0d5d9d964e2249439341746287e918d175f0e3ee241407"
7
8inherit pypi python_setuptools_build_meta
9
10PACKAGECONFIG ??= ""
11PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio"
12PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio"
13PACKAGECONFIG[tornado] = ",,,python3-tornado"
14PACKAGECONFIG[twisted] = ",,,python3-twisted-conch"
15PACKAGECONFIG[redis] = ",,,python3-redis"
16PACKAGECONFIG[sql] = ",,,python3-sqlalchemy"
17
18RDEPENDS:${PN} += " \
19 python3-asyncio \
20 python3-core \
21 python3-io \
22 python3-json \
23 python3-logging \
24 python3-math \
25 python3-netserver \
26"
27
28RDEPENDS:${PN} += " \
29 python3-pyserial \
30 python3-six \
31"