summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymisp_2.4.166.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-12-12 15:38:35 +0800
committerKhem Raj <raj.khem@gmail.com>2022-12-12 11:17:23 -0800
commit9a14806ecb67c52975f2ed3790894d500d2024a4 (patch)
treec0d28bf0ff3fa4f7c67868c7801de7ebc9fc81bd /meta-python/recipes-devtools/python/python3-pymisp_2.4.166.bb
parent8bab5a22cce0f8007e5665c09b957b4f854551d6 (diff)
downloadmeta-openembedded-9a14806ecb67c52975f2ed3790894d500d2024a4.tar.gz
python3-pymisp: upgrade 2.4.165.1 -> 2.4.166
Changelog: ========== New ---- - Basic support for listing, enabling and disabling decaying models. - [tests] Test for local tags. Changes -------- - [types] added azure-application-id. Fix ----- - [describetypes] updated with the latest output from MISP. - [types] added missing type value. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymisp_2.4.166.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.166.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.166.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.166.bb
new file mode 100644
index 000000000..0efcea0b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.166.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
7SRCREV = "24c52813876dd88a92b9fcc4b6c2cd259d80d733"
8S = "${WORKDIR}/git"
9
10inherit python_poetry_core
11
12PIP_INSTALL_PACKAGE = "pymisp"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-dateutil \
16 ${PYTHON_PN}-json \
17 ${PYTHON_PN}-jsonschema \
18 ${PYTHON_PN}-requests \
19 ${PYTHON_PN}-six \
20 ${PYTHON_PN}-deprecated \
21 ${PYTHON_PN}-wrapt \
22"
23
24# Fixes: python3-pymisp requires /bin/bash, but no
25# providers found in RDEPENDS:python3-pymisp? [file-rdep]
26RDEPENDS:${PN} += "bash"