diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-10-23 16:52:56 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-10-23 08:05:02 -0700 |
commit | 8ca1ea73cf6c51fa7db2aa6ecb0b6004338a797e (patch) | |
tree | a69a14b439dbe9a50d5107aeb28219461191a45a /meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb | |
parent | f3de052168bd68267ce32dc8747ef3db8236cbaa (diff) | |
download | meta-openembedded-8ca1ea73cf6c51fa7db2aa6ecb0b6004338a797e.tar.gz |
python3-prompt-toolkit: upgrade 3.0.36 -> 3.0.39
Changelog:
===========
Fixes:
- Fix 'RuntimeError' when '__breakpointhook__' is called from another thread.
- Fix memory leak in filters usage.
- Ensure that key bindings are handled in the right context (when using
contextvars).
- Fix regression in filters. (Use of 'WeakValueDictionary' caused filters to
not be cached).
- Fix 'currentThread()' deprecation warning.
- Fix memory leak in filters.
- Make VERSION tuple numeric.
New features:
- Accept 'in_thread' keyword in 'prompt_toolkit.shortcuts.prompt()'.
- Support the 'NO_COLOR' environment variable.
- Use 24-bit true color now by default on Windows 10/11.
- Add '.run()' method in 'TelnetServer'. (To be used instead of
'.start()/.stop()'.
Breaking changes:
- Subclasses of 'Filter' have to call 'super()' in their '__init__'.
- Drop support for Python 3.6:
* This includes code cleanup for Python 3.6 compatibility.
* Use 'get_running_loop()' instead of 'get_event_loop()'.
* Use 'asyncio.run()' instead of 'asyncio.run_until_complete()'.
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb new file mode 100644 index 000000000..05ff41e7a --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.39.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "Library for building powerful interactive command lines in Python" | ||
2 | HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f" | ||
5 | |||
6 | SRC_URI[sha256sum] = "04505ade687dc26dc4284b1ad19a83be2f2afe83e7a828ace0c72f3a1df72aac" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | PYPI_PACKAGE = "prompt_toolkit" | ||
11 | |||
12 | RDEPENDS:${PN} += " \ | ||
13 | ${PYTHON_PN}-core \ | ||
14 | ${PYTHON_PN}-six \ | ||
15 | ${PYTHON_PN}-terminal \ | ||
16 | ${PYTHON_PN}-threading \ | ||
17 | ${PYTHON_PN}-wcwidth \ | ||
18 | ${PYTHON_PN}-datetime \ | ||
19 | ${PYTHON_PN}-shell \ | ||
20 | ${PYTHON_PN}-image \ | ||
21 | ${PYTHON_PN}-asyncio \ | ||
22 | ${PYTHON_PN}-xml \ | ||
23 | " | ||
24 | |||
25 | BBCLASSEXTEND = "native nativesdk" | ||