summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-01-04 12:00:15 +0200
committerKhem Raj <raj.khem@gmail.com>2023-01-06 11:38:16 -0800
commita695aca353744308eae124d5ebe9691b42778d11 (patch)
tree3c0219a71619eca0818167ee27beb00765232ba7 /meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
parentbbb07140d5024ef15103e67807d03b47bcbd9bc9 (diff)
downloadmeta-openembedded-a695aca353744308eae124d5ebe9691b42778d11.tar.gz
python3-prompt-toolkit: Upgrade 3.0.31 -> 3.0.36
Upgrade to release 3.0.36: - Another Python 3.6 fix for a bug that was introduced in 3.0.34. - Fix bug introduced in 3.0.34 for Python 3.6. Use asynccontextmanager implementation from prompt_toolkit itself. - Improve completion performance in various places. - Improve renderer performance. - Handle `KeyboardInterrupt` when the stacktrace of an unhandled error is displayed. - Use correct event loop in `Application.create_background_task()`. - Fix `show_cursor` attribute in `ScrollablePane`. - Improve termination of `Application`. Don't suppress `CancelledError`. This fixes a race condition when an `Application` gets cancelled while we're waiting for the background tasks to complete. - Fixed typehint for `OneStyleAndTextTuple`. - Small bugfix in `CombinedRegistry`. Fixed missing `@property`. - Use `DummyInput` by default in `create_input()` if `sys.stdin` does not have a valid file descriptor. This fixes errors when `sys.stdin` is patched in certain situations. - Fix control-c key binding for `ProgressBar` when the progress bar was not created from the main thread. The current code would try to kill the main thread when control-c was pressed. - Accept a `cancel_callback` in `ProgressBar` to specify the cancellation behavior for when `control-c` is pressed. - Small performance improvement in the renderer. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
new file mode 100644
index 000000000..a5299318b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
6SRC_URI[sha256sum] = "3e163f254bef5a03b146397d7c1963bd3e2812f0964bb9a24e6ec761fd28db63"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "prompt_toolkit"
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-six \
15 ${PYTHON_PN}-terminal \
16 ${PYTHON_PN}-threading \
17 ${PYTHON_PN}-wcwidth \
18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-image \
21 ${PYTHON_PN}-asyncio \
22 ${PYTHON_PN}-xml \
23"
24
25BBCLASSEXTEND = "native nativesdk"