summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-portion_2.6.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2025-01-17 20:30:30 +0000
committerKhem Raj <raj.khem@gmail.com>2025-01-17 16:39:42 -0800
commit9e3ab586bd611c017e6e99767f2458cdf262e2ef (patch)
tree7053bbbd6c94b90716656e965c3641c7ba8d5907 /meta-python/recipes-devtools/python/python3-portion_2.6.0.bb
parent6bf9389c437be4c449a64ca1dbaaaa94441900dd (diff)
downloadmeta-openembedded-9e3ab586bd611c017e6e99767f2458cdf262e2ef.tar.gz
python3-portion: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-portion_2.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-portion_2.6.0.bb17
1 files changed, 3 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-portion_2.6.0.bb b/meta-python/recipes-devtools/python/python3-portion_2.6.0.bb
index 31c6f07316..8bdbc032cf 100644
--- a/meta-python/recipes-devtools/python/python3-portion_2.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-portion_2.6.0.bb
@@ -5,28 +5,17 @@ SECTION = "devel/python"
5LICENSE = "LGPL-3.0-only" 5LICENSE = "LGPL-3.0-only"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000208d539ec061b899bce1d9ce9404" 6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000208d539ec061b899bce1d9ce9404"
7 7
8inherit pypi python_setuptools_build_meta ptest 8inherit pypi python_setuptools_build_meta ptest-python-pytest
9 9
10SRC_URI[sha256sum] = "6fb538b57a92058f0edd360667694448aa3fc028ab97e41e3091359d14ba4dd5" 10SRC_URI[sha256sum] = "6fb538b57a92058f0edd360667694448aa3fc028ab97e41e3091359d14ba4dd5"
11 11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN} += "\ 12RDEPENDS:${PN} += "\
17 python3-sortedcontainers \ 13 python3-sortedcontainers \
18" 14"
19 15
20RDEPENDS:${PN}-ptest += " \ 16do_install_ptest:append () {
21 python3-pytest \
22 python3-unittest-automake-output \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 # This file tests README.md and deleted as redundant. 17 # This file tests README.md and deleted as redundant.
28 rm -f ${S}/tests/test_doc.py 18 rm -f ${D}/tests/test_doc.py
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30} 19}
31 20
32BBCLASSEXTEND = "native" 21BBCLASSEXTEND = "native"