summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-parse_1.20.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-06-25 16:56:11 +0800
committerKhem Raj <raj.khem@gmail.com>2024-06-27 09:19:00 -0700
commitc11ffc23a5bdfe6e1d49835f01462e293577e7bf (patch)
tree79056f13469835b1c23b601afc6a654c41ee94ed /meta-python/recipes-devtools/python/python3-parse_1.20.1.bb
parent6eea33f83e1968cf91fb52cb677d1e44a2b271f5 (diff)
downloadmeta-openembedded-c11ffc23a5bdfe6e1d49835f01462e293577e7bf.tar.gz
python3-parse: upgrade 1.20.1 -> 1.20.2
Changelog: allow hyphen in field name. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-parse_1.20.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-parse_1.20.1.bb27
1 files changed, 0 insertions, 27 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.20.1.bb b/meta-python/recipes-devtools/python/python3-parse_1.20.1.bb
deleted file mode 100644
index d2b91b3f3..000000000
--- a/meta-python/recipes-devtools/python/python3-parse_1.20.1.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
5
6SRC_URI[sha256sum] = "09002ca350ad42e76629995f71f7b518670bcf93548bdde3684fd55d2be51975"
7
8SRC_URI += " \
9 file://run-ptest \
10"
11
12inherit pypi python_setuptools_build_meta ptest
13
14RDEPENDS:${PN} += "\
15 python3-datetime \
16 python3-logging \
17 python3-numbers \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 python3-pytest \
22 python3-unittest-automake-output \
23"
24
25do_install_ptest() {
26 cp -f ${S}/tests/test*.py ${D}${PTEST_PATH}/
27}