summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-22 13:35:33 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-26 08:55:01 -0700
commit6ea2fdd3c87d047160f0740daf841d8cf7217c17 (patch)
treef11b9eeb2ffbd9357af94d892c9aabdc98491b51 /meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb
parentc9384d7fc40acdf8b5ed668ac3f5fa0e2ad4dbd1 (diff)
downloadmeta-openembedded-6ea2fdd3c87d047160f0740daf841d8cf7217c17.tar.gz
python3-ordered-set: Upgrade 3.1.1 -> 4.0.2
Upgrade to release 4.0.2: - Fix packaging, remove vestiges of type stubs - Code formatting (isort and black) - Directly distribute type stub file via PEP 561 - Include pytest.ini in sdist - Add a Jenkinsfile - Handle another indexing case from NumPy Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb b/meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb
new file mode 100644
index 000000000..0e678b54d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ordered-set_4.0.2.bb
@@ -0,0 +1,23 @@
1SUMMARY = "A MutableSet that remembers its order, so that every entry has an index."
2HOMEPAGE = "http://github.com/LuminosoInsight/ordered-set"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=2b36be0d99854aa2ae292a800a7c1d4e"
5
6SRC_URI[md5sum] = "5d88f3870c32d4868b28c8fe833f7e74"
7SRC_URI[sha256sum] = "ba93b2df055bca202116ec44b9bead3df33ea63a7d5827ff8e16738b97f33a95"
8
9inherit pypi setuptools3 ptest
10
11DEPENDS += "python3-pytest-runner-native"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS_${PN}-ptest += " \
18 ${PYTHON_PN}-pytest \
19"
20
21do_install_ptest() {
22 cp -f ${S}/test.py ${D}${PTEST_PATH}/
23}