diff options
author | Khem Raj <raj.khem@gmail.com> | 2025-04-08 11:43:41 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-04-08 11:46:18 -0700 |
commit | a8faf50d38cb8f8d53b08f20262854a3fa6bae4a (patch) | |
tree | 0593905e121aaf0ab4ec22ab9ba124e5e17d35fb /meta-python/recipes-devtools/python/python3-objgraph_3.6.2.bb | |
parent | fc28826b61f4d0f4ed2f28951e1c82babfd52496 (diff) | |
download | meta-openembedded-a8faf50d38cb8f8d53b08f20262854a3fa6bae4a.tar.gz |
python3-objgraph: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-objgraph_3.6.2.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-objgraph_3.6.2.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-objgraph_3.6.2.bb b/meta-python/recipes-devtools/python/python3-objgraph_3.6.2.bb new file mode 100644 index 0000000000..a17b7aa5d6 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-objgraph_3.6.2.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Draws Python object reference graphs with graphviz" | ||
2 | HOMEPAGE = "https://mg.pov.lt/objgraph/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e48a556235f55ad7d4234475657f68a7" | ||
5 | |||
6 | SRC_URI:append = " file://run-ptest" | ||
7 | SRC_URI[sha256sum] = "00b9f2f40f7422e3c7f45a61c4dafdaf81f03ff0649d6eaec866f01030e51ad8" | ||
8 | |||
9 | inherit pypi setuptools3 ptest-python-pytest | ||
10 | |||
11 | PACKAGECONFIG ??= "" | ||
12 | PACKAGECONFIG[ipython] = ",,,python3-graphviz" | ||
13 | |||
14 | do_install_ptest:append() { | ||
15 | install -Dm 0644 ${S}/tests.py ${D}${PTEST_PATH}/tests.py | ||
16 | } | ||
17 | |||
18 | RDEPENDS:${PN} += "python3-core python3-io" | ||
19 | RDEPENDS:${PN}-ptest += "python3-tox" | ||
20 | |||
21 | PYPI_PACKAGE = "objgraph" | ||