summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-marshmallow_3.17.1.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-09-02 09:36:38 +0800
committerKhem Raj <raj.khem@gmail.com>2022-09-03 12:20:15 -0700
commitf5eae9cc486ecce4d9c8e127b020174d14f8c2a5 (patch)
treeea3d0cf0d0cf3197daf89ad3fac6acbd6fadb61c /meta-python/recipes-devtools/python/python3-marshmallow_3.17.1.bb
parenta7b990fff1908cf43deb2dc3ff6b92598be34644 (diff)
downloadmeta-openembedded-f5eae9cc486ecce4d9c8e127b020174d14f8c2a5.tar.gz
python3-marshmallow: upgrade 3.17.0 -> 3.17.1
Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-marshmallow_3.17.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-marshmallow_3.17.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.17.1.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.17.1.bb
new file mode 100644
index 000000000..a7f4020cf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.17.1.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Simplified object serialization in python"
2DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
3AUTHOR = "Marius Kriegerowski <mk@quakesaver.net>"
4HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "\
7 file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \
8 file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
9
10SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
11
12SRCREV = "22e063270fea6ef6669425f53216e47eb8b04cc5"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
18PIP_INSTALL_PACKAGE = "marshmallow"
19
20RDEPENDS:${PN} += " \
21 python3-core \
22 python3-datetime \
23 python3-netclient \
24 python3-numbers \
25 python3-json \
26 python3-pprint \
27 python3-packaging \
28"