diff options
author | zangrc <zangrc.fnst@fujitsu.com> | 2021-07-05 09:55:53 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-07-06 09:40:42 -0700 |
commit | eb7030939983dc4fc5dfb29e4f0ef4e4b4d3f505 (patch) | |
tree | d91b9654b588215602e241f068311df28682bedb /meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch | |
parent | f7f1c9fb2d63ae4f5e06e91355295a17016b7502 (diff) | |
download | meta-openembedded-eb7030939983dc4fc5dfb29e4f0ef4e4b4d3f505.tar.gz |
python3-m2crypto: upgrade 0.37.1 -> 0.38.0
0.38.0 - 2021-06-14
-------------------
- Remove the last use of setup.py test idiom.
- Use m2_PyObject_AsReadBuffer instead of PyObject_AsReadBuffer.
- Add support for arm64 big endian <Steev Klimaszewski>
- Make support of RSA_SSLV23_PADDING optional (it has been deprecated).
- Move project to src/ layout
- Allow verify_cb_* to be called with ok=True <Casey Deccio>
- Be prepared if any of constants in x509_vfy.h is not available.
- But we do support 3.8
- We DO NOT support Python 2.6.
Refresh the following patch:
cross-compile-platform.patch
0001-Allow-verify_cb_-to-be-called-with-ok-True.patch
0001-Use-of-RSA_SSLV23_PADDING-has-been-deprecated.patch
Removed since these are included in 0.38.0
Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch b/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch index f039ae866..77ef7e557 100644 --- a/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch +++ b/meta-python/recipes-devtools/python/python3-m2crypto/cross-compile-platform.patch | |||
@@ -6,7 +6,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
6 | 6 | ||
7 | --- a/setup.py | 7 | --- a/setup.py |
8 | +++ b/setup.py | 8 | +++ b/setup.py |
9 | @@ -169,22 +169,6 @@ class _M2CryptoBuildExt(build_ext.build_ | 9 | @@ -169,24 +169,6 @@ class _M2CryptoBuildExt(build_ext.build_ |
10 | log.debug('self.include_dirs = %s', self.include_dirs) | 10 | log.debug('self.include_dirs = %s', self.include_dirs) |
11 | log.debug('self.library_dirs = %s', self.library_dirs) | 11 | log.debug('self.library_dirs = %s', self.library_dirs) |
12 | 12 | ||
@@ -25,6 +25,8 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
25 | - self.swig_opts.append('-D%s' % arch) | 25 | - self.swig_opts.append('-D%s' % arch) |
26 | - if mach in ('ppc64le', 'ppc64el'): | 26 | - if mach in ('ppc64le', 'ppc64el'): |
27 | - self.swig_opts.append('-D_CALL_ELF=2') | 27 | - self.swig_opts.append('-D_CALL_ELF=2') |
28 | - if mach in ('arm64_be'): | ||
29 | - self.swig_opts.append('-D__AARCH64EB__') | ||
28 | - | 30 | - |
29 | self.swig_opts.extend(['-I%s' % i for i in self.include_dirs]) | 31 | self.swig_opts.extend(['-I%s' % i for i in self.include_dirs]) |
30 | 32 | ||