summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-lxml_4.5.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-10 13:19:14 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:44:18 -0700
commit332b5df1f3437015efbc8191296283015d50ff9b (patch)
treef79da8923b4b9ef9a707a7ecb173b70ca7130adb /meta-python/recipes-devtools/python/python3-lxml_4.5.1.bb
parent5cc970c1d87fbde9e1c8261fa0edcd71d2e89b96 (diff)
downloadmeta-openembedded-332b5df1f3437015efbc8191296283015d50ff9b.tar.gz
python3-lxml: Upgrade 4.5.0 -> 4.5.1
Upgrade to release 4.5.1. With this release we no longer need to specify --with-xml2-config='pkg-config libxml-2.0' or equivalent for libxslt. Following the recent modifications of setupinfo.py to use pkg-config, we just need build without flags. Suggested-by: Stefan Behnel <stefan_ml@behnel.de> Suggested-by: Hugh McMaster <hugh.mcmaster@outlook.com> Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lxml_4.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_4.5.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lxml_4.5.1.bb b/meta-python/recipes-devtools/python/python3-lxml_4.5.1.bb
new file mode 100644
index 000000000..a4198b029
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lxml_4.5.1.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
2DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
3libxslt libraries. It provides safe and convenient access to these \
4libraries using the ElementTree API. It extends the ElementTree API \
5significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
6C14N and much more."
7HOMEPAGE = "http://codespeak.net/lxml"
8SECTION = "devel/python"
9LICENSE = "BSD & GPLv2 & MIT & PSF"
10LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
11 file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
12 file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
13 file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
14 file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
15 file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
16 file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
17 "
18
19DEPENDS += "libxml2 libxslt"
20
21SRC_URI[md5sum] = "4d3cca9c0018dd98f39e0ac54fcc3d14"
22SRC_URI[sha256sum] = "27ee0faf8077c7c1a589573b1450743011117f1aa1a91d5ae776bbc5ca6070f2"
23
24inherit pypi setuptools3
25
26# {standard input}: Assembler messages:
27# {standard input}:1488805: Error: branch out of range
28DEBUG_OPTIMIZATION_remove_mips = " -Og"
29DEBUG_OPTIMIZATION_append_mips = " -O"
30BUILD_OPTIMIZATION_remove_mips = " -Og"
31BUILD_OPTIMIZATION_append_mips = " -O"
32
33DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
34DEBUG_OPTIMIZATION_append_mipsel = " -O"
35BUILD_OPTIMIZATION_remove_mipsel = " -Og"
36BUILD_OPTIMIZATION_append_mipsel = " -O"
37
38BBCLASSEXTEND = "native nativesdk"
39
40RDEPENDS_${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
41
42CLEANBROKEN = "1"